CVE-2020-8897
CVE-2020-8897 · Robustness weakness in AWS KMS and Encryption SDKs
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A weak robustness vulnerability exists in the AWS Encryption SDKs for Java, Python, C and Javalcript prior to versions 2.0.0. Due to the non-committing property of AES-GCM (and other AEAD ciphers such as AES-GCM-SIV or (X)ChaCha20Poly1305) used by the SDKs to encrypt messages, an attacker can craft a unique cyphertext which will decrypt to multiple different results, and becomes especially relevant in a multi-recipient setting. We recommend users update their SDK to 2.0.0 or later.
CVSS 4.8 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
aws sdk
- Softwareversionen
- ≥ stable, < 2.0.0: Betroffen (custom)
Auf 2.0.0 aktualisieren
com.amazonaws:aws-encryption-sdk-java Maven
- Softwareversionen
- 0.0.1
- 1.3.0
- 1.3.1
- 1.3.1-STAGING
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.6.1
- 1.6.2
- 1.7.0
- 1.9.0
- 1.9.1
- 1.9.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.0
Auf 2.0.0 aktualisieren
aws-encryption-sdk PyPI
- Softwareversionen
- 1.10.0
- 1.10.1
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.0
Auf 2.0.0 aktualisieren
aws-encryption-sdk PyPI
- Softwareversionen
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- 1.10.0
- 1.10.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.0
Auf 2.0.0 aktualisieren