CVE-2020-8897
CVE-2020-8897 · Robustness weakness in AWS KMS and Encryption SDKs
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A weak robustness vulnerability exists in the AWS Encryption SDKs for Java, Python, C and Javalcript prior to versions 2.0.0. Due to the non-committing property of AES-GCM (and other AEAD ciphers such as AES-GCM-SIV or (X)ChaCha20Poly1305) used by the SDKs to encrypt messages, an attacker can craft a unique cyphertext which will decrypt to multiple different results, and becomes especially relevant in a multi-recipient setting. We recommend users update their SDK to 2.0.0 or later.
CVSS 4.8 · Medium · EPSS 0.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
aws sdk
- Versions
- ≥ stable, < 2.0.0: Affected (custom)
Update to 2.0.0
com.amazonaws:aws-encryption-sdk-java Maven
- Versions
- 0.0.1
- 1.3.0
- 1.3.1
- 1.3.1-STAGING
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.4.0
- 1.4.1
- 1.5.0
- 1.6.0
- 1.6.1
- 1.6.2
- 1.7.0
- 1.9.0
- 1.9.1
- 1.9.2
- Affected ranges
- ECOSYSTEM: < 2.0.0
Update to 2.0.0
aws-encryption-sdk PyPI
- Versions
- 1.10.0
- 1.10.1
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- Affected ranges
- ECOSYSTEM: < 2.0.0
Update to 2.0.0
aws-encryption-sdk PyPI
- Versions
- 1.2.0
- 1.2.2
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.7.1
- 1.9.0
- 1.10.0
- 1.10.1
- Affected ranges
- ECOSYSTEM: < 2.0.0
Update to 2.0.0