p PatchFirst

CVE-2021-21334

CVE-2021-21334 · environment variable leak

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.

CVSS 6.3 · Mittel · EPSS 1,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · containers

Betroffene Produkte und Versionen

  • containerd

    Softwareversionen
    • < 1.3.10: Betroffen
    • >= 1.4.0, < 1.4.4: Betroffen

    Keine Korrektur veröffentlicht

  • containerd Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.4~ds1-1

    Auf 1.4.4~ds1-1 aktualisieren

  • containerd Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.4~ds1-1

    Auf 1.4.4~ds1-1 aktualisieren

  • containerd Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.4~ds1-1

    Auf 1.4.4~ds1-1 aktualisieren

  • containerd Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    • 1.2.6-0ubuntu1~16.04.6+esm2
    • 1.2.6-0ubuntu1~16.04.6+esm4
    • 1.2.6-0ubuntu1~16.04.6+esm5
    • 1.2.6-0ubuntu1~16.04.6+esm6
    • 1.2.6-0ubuntu1~16.04.6+esm7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • containerd Ubuntu:18.04:LTS

    Softwareversionen
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.2

    Auf 1.5.2-0ubuntu1~18.04.2 aktualisieren

  • containerd Ubuntu:20.04:LTS

    Softwareversionen
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.3.3-0ubuntu2.3

    Auf 1.3.3-0ubuntu2.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →