CVE-2021-21334
CVE-2021-21334 · environment variable leak
This page contains facts from public vulnerability sources. Check the original advisory before updating.
In containerd (an industry-standard container runtime) before versions 1.3.10 and 1.4.4, containers launched through containerd's CRI implementation (through Kubernetes, crictl, or any other pod/container client that uses the containerd CRI service) that share the same image may receive incorrect environment variables, including values that are defined for other containers. If the affected containers have different security contexts, this may allow sensitive information to be unintentionally shared. If you are not using containerd's CRI implementation (through one of the mechanisms described above), you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image which have different environment variables, you are not vulnerable to this issue. If you are not launching multiple containers or Kubernetes pods from the same image in rapid succession, you have reduced likelihood of being vulnerable to this issue This vulnerability has been fixed in containerd 1.3.10 and containerd 1.4.4. Users should update to these versions.
CVSS 6.3 · Medium · EPSS 1.9% · Fix available
- Published
- Updated
Stack: system · containers
Affected products and versions
containerd
- Versions
- < 1.3.10: Affected
- >= 1.4.0, < 1.4.4: Affected
No fix published
containerd Debian:12
- Affected ranges
- ECOSYSTEM: < 1.4.4~ds1-1
Update to 1.4.4~ds1-1
containerd Debian:13
- Affected ranges
- ECOSYSTEM: < 1.4.4~ds1-1
Update to 1.4.4~ds1-1
containerd Debian:14
- Affected ranges
- ECOSYSTEM: < 1.4.4~ds1-1
Update to 1.4.4~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versions
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- 1.2.6-0ubuntu1~16.04.6+esm2
- 1.2.6-0ubuntu1~16.04.6+esm4
- 1.2.6-0ubuntu1~16.04.6+esm5
- 1.2.6-0ubuntu1~16.04.6+esm6
- 1.2.6-0ubuntu1~16.04.6+esm7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
containerd Ubuntu:18.04:LTS
- Versions
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- Affected ranges
- ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.2
Update to 1.5.2-0ubuntu1~18.04.2
containerd Ubuntu:20.04:LTS
- Versions
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- Affected ranges
- ECOSYSTEM: < 1.3.3-0ubuntu2.3
Update to 1.3.3-0ubuntu2.3
Original sources
- https://github.com/containerd/containerd/security/advisories/GHSA-6g2q-w5j3-fwh4
- https://github.com/containerd/containerd/releases/tag/v1.4.4
- https://github.com/containerd/containerd/releases/tag/v1.3.10
- https://github.com/containerd/containerd/commit/05f951a3781f4f2c1911b05e61c160e9c30eaa8e
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/KUE2Z2ZUWBHRU36ZGBD2YSJCYB6ELPXE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/QIBPKSX5IOWPM3ZPFB3JVLXWDHSZTTWT/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/VTXHA5JOWQRCCUZH7ZQBEYN6KZKJEYSD/
- https://security.gentoo.org/glsa/202105-33
- https://nvd.nist.gov/vuln/detail/CVE-2021-21334