p PatchFirst

CVE-2021-32809

CVE-2021-32809 · Arbitrary HTML injection vulnerability in ckeditor

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

ckeditor is an open source WYSIWYG HTML editor with rich content support. A potential vulnerability has been discovered in CKEditor 4 [Clipboard](https://ckeditor.com/cke4/addon/clipboard) package. The vulnerability allowed to abuse paste functionality using malformed HTML, which could result in injecting arbitrary HTML into the editor. It affects all users using the CKEditor 4 plugins listed above at version >= 4.5.2. The problem has been recognized and patched. The fix will be available in version 4.16.2.

CVSS 4.6 · Mittel · EPSS 1,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • ckeditor4

    Softwareversionen
    • >= 4.5.2, < 4.16.2: Betroffen

    Keine Korrektur veröffentlicht

  • ckeditor Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.16.2+dfsg-1

    Auf 4.16.2+dfsg-1 aktualisieren

  • ckeditor4 npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.5.2, < 4.16.2

    Auf 4.16.2 aktualisieren

  • ckeditor Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 4.4.4+dfsg1-3
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.7+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.16.04.1~esm1

    Auf 4.5.7+dfsg-2ubuntu0.16.04.1~esm1 aktualisieren

  • ckeditor Ubuntu:18.04:LTS

    Softwareversionen
    • 4.5.7+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.5.7+dfsg-2ubuntu0.18.04.1

    Auf 4.5.7+dfsg-2ubuntu0.18.04.1 aktualisieren

  • ckeditor Ubuntu:20.04:LTS

    Softwareversionen
    • 4.11.1+dfsg-1
    • 4.12.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.12.1+dfsg-1ubuntu0.1

    Auf 4.12.1+dfsg-1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →