p PatchFirst

CVE-2021-33560

CVE-2021-33560

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.

CVSS 7.5 · Hoch · EPSS 2,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • libgcrypt20 Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.4-2

    Auf 1.9.4-2 aktualisieren

  • libgcrypt20 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.4-2

    Auf 1.9.4-2 aktualisieren

  • libgcrypt20 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.4-2

    Auf 1.9.4-2 aktualisieren

  • libgcrypt20 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.3-2ubuntu1
    • 1.6.4-3
    • 1.6.4-4
    • 1.6.4-5
    • 1.6.5-2
    • 1.6.5-2ubuntu0.2
    • 1.6.5-2ubuntu0.3
    • 1.6.5-2ubuntu0.4
    • 1.6.5-2ubuntu0.5
    • 1.6.5-2ubuntu0.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.6.5-2ubuntu0.6+esm1

    Auf 1.6.5-2ubuntu0.6+esm1 aktualisieren

  • libgcrypt20 Ubuntu:18.04:LTS

    Softwareversionen
    • 1.7.8-2ubuntu1
    • 1.7.9-1
    • 1.8.1-4
    • 1.8.1-4ubuntu1
    • 1.8.1-4ubuntu1.1
    • 1.8.1-4ubuntu1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.1-4ubuntu1.3

    Auf 1.8.1-4ubuntu1.3 aktualisieren

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS

    Softwareversionen
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.1-4ubuntu1.fips.3

    Auf 1.8.1-4ubuntu1.fips.3 aktualisieren

  • libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS

    Softwareversionen
    • 1.8.1-4ubuntu1.fips.2.4
    • 1.8.1-4ubuntu1.fips.2.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libgcrypt20 Ubuntu:20.04:LTS

    Softwareversionen
    • 1.8.4-5ubuntu2
    • 1.8.5-3ubuntu1
    • 1.8.5-5ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.5-5ubuntu1.1

    Auf 1.8.5-5ubuntu1.1 aktualisieren

  • libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1

    Auf 1.8.5-5ubuntu1.fips.1.1 aktualisieren

  • libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1

    Auf 1.8.5-5ubuntu1.fips.1.1 aktualisieren

  • libgcrypt20 Ubuntu:22.04:LTS

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.8.7-5ubuntu2

    Auf 1.8.7-5ubuntu2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →