CVE-2021-33560
CVE-2021-33560
This page contains facts from public vulnerability sources. Check the original advisory before updating.
Libgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.
CVSS 7.5 · High · EPSS 2.4% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
n/a
- Versions
- n/a: Affected
No fix published
libgcrypt20 Debian:12
- Affected ranges
- ECOSYSTEM: < 1.9.4-2
Update to 1.9.4-2
libgcrypt20 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.9.4-2
Update to 1.9.4-2
libgcrypt20 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.9.4-2
Update to 1.9.4-2
libgcrypt20 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.3-2ubuntu1
- 1.6.4-3
- 1.6.4-4
- 1.6.4-5
- 1.6.5-2
- 1.6.5-2ubuntu0.2
- 1.6.5-2ubuntu0.3
- 1.6.5-2ubuntu0.4
- 1.6.5-2ubuntu0.5
- 1.6.5-2ubuntu0.6
- Affected ranges
- ECOSYSTEM: < 1.6.5-2ubuntu0.6+esm1
Update to 1.6.5-2ubuntu0.6+esm1
libgcrypt20 Ubuntu:18.04:LTS
- Versions
- 1.7.8-2ubuntu1
- 1.7.9-1
- 1.8.1-4
- 1.8.1-4ubuntu1
- 1.8.1-4ubuntu1.1
- 1.8.1-4ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 1.8.1-4ubuntu1.3
Update to 1.8.1-4ubuntu1.3
libgcrypt20 Ubuntu:Pro:FIPS-updates:18.04:LTS
- Versions
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Affected ranges
- ECOSYSTEM: < 1.8.1-4ubuntu1.fips.3
Update to 1.8.1-4ubuntu1.fips.3
libgcrypt20 Ubuntu:Pro:FIPS:18.04:LTS
- Versions
- 1.8.1-4ubuntu1.fips.2.4
- 1.8.1-4ubuntu1.fips.2.5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
libgcrypt20 Ubuntu:20.04:LTS
- Versions
- 1.8.4-5ubuntu2
- 1.8.5-3ubuntu1
- 1.8.5-5ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.8.5-5ubuntu1.1
Update to 1.8.5-5ubuntu1.1
libgcrypt20 Ubuntu:Pro:FIPS-updates:20.04:LTS
- Affected ranges
- ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1
Update to 1.8.5-5ubuntu1.fips.1.1
libgcrypt20 Ubuntu:Pro:FIPS:20.04:LTS
- Affected ranges
- ECOSYSTEM: < 1.8.5-5ubuntu1.fips.1.1
Update to 1.8.5-5ubuntu1.fips.1.1
libgcrypt20 Ubuntu:22.04:LTS
- Affected ranges
- ECOSYSTEM: < 1.8.7-5ubuntu2
Update to 1.8.7-5ubuntu2
Original sources
- https://dev.gnupg.org/T5328
- https://lists.debian.org/debian-lts-announce/2021/06/msg00021.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/R7OAPCUGPF3VLA7QAJUQSL255D4ITVTL/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/BKKTOIGFW2SGN3DO2UHHVZ7MJSYN4AAB/
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://dev.gnupg.org/T5466
- https://dev.gnupg.org/T5305
- https://dev.gnupg.org/rCe8b7f10be275bcedb5fc05ed4837a89bfd605c61
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://security.gentoo.org/glsa/202210-13
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-33560