p PatchFirst

CVE-2021-3999

CVE-2021-3999

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A flaw was found in glibc. An off-by-one buffer overflow and underflow in getcwd() may lead to memory corruption when the size of the buffer is exactly 1. A local attacker who can control the input buffer and size passed to getcwd() in a setuid program could use this flaw to potentially execute arbitrary code and escalate their privileges on the system.

CVSS 7.8 · Hoch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • glibc

    Softwareversionen
    • Fixed in glibc v2.31 and above.: Betroffen

    Keine Korrektur veröffentlicht

  • glibc Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.33-4

    Auf 2.33-4 aktualisieren

  • glibc Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.33-4

    Auf 2.33-4 aktualisieren

  • glibc Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.33-4

    Auf 2.33-4 aktualisieren

  • eglibc Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 2.17-93ubuntu4
    • 2.18-0ubuntu1
    • 2.18-0ubuntu2
    • 2.18-0ubuntu4
    • 2.18-0ubuntu5
    • 2.18-0ubuntu6
    • 2.18-0ubuntu7
    • 2.19-0ubuntu2
    • 2.19-0ubuntu3
    • 2.19-0ubuntu4
    • 2.19-0ubuntu5
    • 2.19-0ubuntu6
    • 2.19-0ubuntu6.1
    • 2.19-0ubuntu6.3
    • 2.19-0ubuntu6.4
    • 2.19-0ubuntu6.5
    • 2.19-0ubuntu6.6
    • 2.19-0ubuntu6.7
    • 2.19-0ubuntu6.8
    • 2.19-0ubuntu6.9
    • 2.19-0ubuntu6.10
    • 2.19-0ubuntu6.11
    • 2.19-0ubuntu6.13
    • 2.19-0ubuntu6.14
    • 2.19-0ubuntu6.15
    • 2.19-0ubuntu6.15+esm1
    • 2.19-0ubuntu6.15+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.19-0ubuntu6.15+esm3

    Auf 2.19-0ubuntu6.15+esm3 aktualisieren

  • glibc Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.21-0ubuntu4
    • 2.21-0ubuntu5
    • 2.21-0ubuntu6
    • 2.23-0ubuntu1
    • 2.23-0ubuntu2
    • 2.23-0ubuntu3
    • 2.23-0ubuntu4
    • 2.23-0ubuntu5
    • 2.23-0ubuntu6
    • 2.23-0ubuntu7
    • 2.23-0ubuntu9
    • 2.23-0ubuntu10
    • 2.23-0ubuntu11
    • 2.23-0ubuntu11.2
    • 2.23-0ubuntu11.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.23-0ubuntu11.3+esm1

    Auf 2.23-0ubuntu11.3+esm1 aktualisieren

  • glibc Ubuntu:18.04:LTS

    Softwareversionen
    • 2.26-0ubuntu2
    • 2.26-0ubuntu2.1
    • 2.27-0ubuntu2
    • 2.27-0ubuntu3
    • 2.27-3ubuntu1
    • 2.27-3ubuntu1.2
    • 2.27-3ubuntu1.3
    • 2.27-3ubuntu1.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.27-3ubuntu1.5

    Auf 2.27-3ubuntu1.5 aktualisieren

  • glibc Ubuntu:20.04:LTS

    Softwareversionen
    • 2.30-0ubuntu2
    • 2.30-0ubuntu3
    • 2.31-0ubuntu5
    • 2.31-0ubuntu6
    • 2.31-0ubuntu7
    • 2.31-0ubuntu9
    • 2.31-0ubuntu9.1
    • 2.31-0ubuntu9.2
    • 2.31-0ubuntu9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.31-0ubuntu9.7

    Auf 2.31-0ubuntu9.7 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →