CVE-2021-3999
CVE-2021-3999
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A flaw was found in glibc. An off-by-one buffer overflow and underflow in getcwd() may lead to memory corruption when the size of the buffer is exactly 1. A local attacker who can control the input buffer and size passed to getcwd() in a setuid program could use this flaw to potentially execute arbitrary code and escalate their privileges on the system.
CVSS 7.8 · High · EPSS 0.8% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
glibc
- Versions
- Fixed in glibc v2.31 and above.: Affected
No fix published
glibc Debian:12
- Affected ranges
- ECOSYSTEM: < 2.33-4
Update to 2.33-4
glibc Debian:13
- Affected ranges
- ECOSYSTEM: < 2.33-4
Update to 2.33-4
glibc Debian:14
- Affected ranges
- ECOSYSTEM: < 2.33-4
Update to 2.33-4
eglibc Ubuntu:Pro:14.04:LTS
- Versions
- 2.17-93ubuntu4
- 2.18-0ubuntu1
- 2.18-0ubuntu2
- 2.18-0ubuntu4
- 2.18-0ubuntu5
- 2.18-0ubuntu6
- 2.18-0ubuntu7
- 2.19-0ubuntu2
- 2.19-0ubuntu3
- 2.19-0ubuntu4
- 2.19-0ubuntu5
- 2.19-0ubuntu6
- 2.19-0ubuntu6.1
- 2.19-0ubuntu6.3
- 2.19-0ubuntu6.4
- 2.19-0ubuntu6.5
- 2.19-0ubuntu6.6
- 2.19-0ubuntu6.7
- 2.19-0ubuntu6.8
- 2.19-0ubuntu6.9
- 2.19-0ubuntu6.10
- 2.19-0ubuntu6.11
- 2.19-0ubuntu6.13
- 2.19-0ubuntu6.14
- 2.19-0ubuntu6.15
- 2.19-0ubuntu6.15+esm1
- 2.19-0ubuntu6.15+esm2
- Affected ranges
- ECOSYSTEM: < 2.19-0ubuntu6.15+esm3
Update to 2.19-0ubuntu6.15+esm3
glibc Ubuntu:Pro:16.04:LTS
- Versions
- 2.21-0ubuntu4
- 2.21-0ubuntu5
- 2.21-0ubuntu6
- 2.23-0ubuntu1
- 2.23-0ubuntu2
- 2.23-0ubuntu3
- 2.23-0ubuntu4
- 2.23-0ubuntu5
- 2.23-0ubuntu6
- 2.23-0ubuntu7
- 2.23-0ubuntu9
- 2.23-0ubuntu10
- 2.23-0ubuntu11
- 2.23-0ubuntu11.2
- 2.23-0ubuntu11.3
- Affected ranges
- ECOSYSTEM: < 2.23-0ubuntu11.3+esm1
Update to 2.23-0ubuntu11.3+esm1
glibc Ubuntu:18.04:LTS
- Versions
- 2.26-0ubuntu2
- 2.26-0ubuntu2.1
- 2.27-0ubuntu2
- 2.27-0ubuntu3
- 2.27-3ubuntu1
- 2.27-3ubuntu1.2
- 2.27-3ubuntu1.3
- 2.27-3ubuntu1.4
- Affected ranges
- ECOSYSTEM: < 2.27-3ubuntu1.5
Update to 2.27-3ubuntu1.5
glibc Ubuntu:20.04:LTS
- Versions
- 2.30-0ubuntu2
- 2.30-0ubuntu3
- 2.31-0ubuntu5
- 2.31-0ubuntu6
- 2.31-0ubuntu7
- 2.31-0ubuntu9
- 2.31-0ubuntu9.1
- 2.31-0ubuntu9.2
- 2.31-0ubuntu9.3
- Affected ranges
- ECOSYSTEM: < 2.31-0ubuntu9.7
Update to 2.31-0ubuntu9.7
Original sources
- https://www.openwall.com/lists/oss-security/2022/01/24/4
- https://sourceware.org/bugzilla/show_bug.cgi?id=28769
- https://sourceware.org/git/gitweb.cgi?p=glibc.git%3Bh=23e0e8f5f1fb5ed150253d986ecccdc90c2dcd5e
- https://bugzilla.redhat.com/show_bug.cgi?id=2024637
- https://access.redhat.com/security/cve/CVE-2021-3999
- https://security-tracker.debian.org/tracker/CVE-2021-3999
- https://lists.debian.org/debian-lts-announce/2022/10/msg00021.html
- https://security.netapp.com/advisory/ntap-20221104-0001/
- https://cert-portal.siemens.com/productcert/html/ssa-831302.html
- https://cert-portal.siemens.com/productcert/html/ssa-398330.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-3999