p PatchFirst

CVE-2021-41165

CVE-2021-41165 · HTML comments vulnerability allowing to execute JavaScript code

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

CVSS 8.2 · Hoch · EPSS 1,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php · node

Betroffene Produkte und Versionen

  • ckeditor4

    Softwareversionen
    • < 4.17.0: Betroffen

    Keine Korrektur veröffentlicht

  • ckeditor Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.19.0+dfsg-1

    Auf 4.19.0+dfsg-1 aktualisieren

  • ckeditor3 Debian:12

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor4 npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.17.0

    Auf 4.17.0 aktualisieren

  • ckeditor/ckeditor Packagist

    Softwareversionen
    • 4.10.0
    • 4.10.1
    • 4.11.0
    • 4.11.1
    • 4.11.2
    • 4.11.3
    • 4.11.4
    • 4.12.0
    • 4.12.1
    • 4.13.0
    • 4.13.1
    • 4.14.0
    • 4.14.1
    • 4.15.0
    • 4.15.1
    • 4.16.0
    • 4.16.1
    • 4.16.2
    • 4.3.3
    • 4.3.4
    • 4.3.5
    • 4.4.0
    • 4.4.1
    • 4.4.2
    • 4.4.3
    • 4.4.4
    • 4.4.5
    • 4.4.6
    • 4.4.7
    • 4.4.8
    • 4.5.0
    • 4.5.1
    • 4.5.10
    • 4.5.11
    • 4.5.2
    • 4.5.3
    • 4.5.4
    • 4.5.5
    • 4.5.6
    • 4.5.7
    • 4.5.8
    • 4.5.9
    • 4.6.0
    • 4.6.1
    • 4.6.2
    • 4.7.0
    • 4.7.1
    • 4.7.2
    • 4.7.3
    • 4.8.0
    • 4.9.0
    • 4.9.1
    • 4.9.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.17.0

    Auf 4.17.0 aktualisieren

  • ckeditor Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 4.4.4+dfsg1-3
    • 4.5.6+dfsg-1
    • 4.5.7+dfsg-1
    • 4.5.7+dfsg-2
    • 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
    • 4.5.7+dfsg-2ubuntu0.16.04.1~esm2
    • 4.5.7+dfsg-2ubuntu0.16.04.1~esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:16.04:LTS

    Softwareversionen
    • 4.9-1
    • 5.1-1
    • 5.2-1
    • 5.2-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:16.04:LTS

    Softwareversionen
    • 4.2.11-2
    • 4.2.12-3
    • 4.2.12-4
    • 4.2.12-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.5.7+dfsg-2
    • 4.5.7+dfsg-2ubuntu0.18.04.1
    • 4.5.7+dfsg-2ubuntu0.18.04.1+esm1
    • 4.5.7+dfsg-2ubuntu0.18.04.1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:18.04:LTS

    Softwareversionen
    • 5.7-1
    • 6.1-1
    • 6.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.4.1-5
    • 4.4.2-1
    • 4.4.2-2
    • 4.4.2-2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 4.11.1+dfsg-1
    • 4.12.1+dfsg-1
    • 4.12.1+dfsg-1ubuntu0.1
    • 4.12.1+dfsg-1ubuntu0.1+esm1
    • 4.12.1+dfsg-1ubuntu0.1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:20.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-3
    • 3.6.6.1+dfsg-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:20.04:LTS

    Softwareversionen
    • 6.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:20.04:LTS

    Softwareversionen
    • 4.4.3-2
    • 4.4.3-2+deb10u3build0.20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:22.04:LTS

    Softwareversionen
    • 7.5-1
    • 7.7-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:22.04:LTS

    Softwareversionen
    • 4.4.4+dfsg-2ubuntu1
    • 4.4.4+dfsg-2ubuntu1.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 4.16.0+dfsg-2
    • 4.16.2+dfsg-1
    • 4.16.2+dfsg-1ubuntu0.1~esm1
    • 4.16.2+dfsg-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ckeditor3 Ubuntu:24.04:LTS

    Softwareversionen
    • 3.6.6.1+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:24.04:LTS

    Softwareversionen
    • 8.3-1
    • 8.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • request-tracker4 Ubuntu:24.04:LTS

    Softwareversionen
    • 4.4.4+dfsg-2ubuntu1
    • 4.4.4+dfsg-2ubuntu2
    • 4.4.7+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ldap-account-manager Ubuntu:25.10

    Softwareversionen
    • 9.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →