CVE-2021-41165
CVE-2021-41165 · HTML comments vulnerability allowing to execute JavaScript code
This page contains facts from public vulnerability sources. Check the original advisory before updating.
This page shows selected source facts. See the linked advisories for the complete description and affected versions.
CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.
CVSS 8.2 · High · EPSS 1.6% · Fix available
- Published
- Updated
Affected products and versions
ckeditor4
- Versions
- < 4.17.0: Affected
No fix published
ckeditor Debian:12
- Affected ranges
- ECOSYSTEM: < 4.19.0+dfsg-1
Update to 4.19.0+dfsg-1
ckeditor3 Debian:12
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor4 npm
- Affected ranges
- SEMVER: < 4.17.0
Update to 4.17.0
ckeditor/ckeditor Packagist
- Versions
- 4.10.0
- 4.10.1
- 4.11.0
- 4.11.1
- 4.11.2
- 4.11.3
- 4.11.4
- 4.12.0
- 4.12.1
- 4.13.0
- 4.13.1
- 4.14.0
- 4.14.1
- 4.15.0
- 4.15.1
- 4.16.0
- 4.16.1
- 4.16.2
- 4.3.3
- 4.3.4
- 4.3.5
- 4.4.0
- 4.4.1
- 4.4.2
- 4.4.3
- 4.4.4
- 4.4.5
- 4.4.6
- 4.4.7
- 4.4.8
- 4.5.0
- 4.5.1
- 4.5.10
- 4.5.11
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.1
- 4.6.2
- 4.7.0
- 4.7.1
- 4.7.2
- 4.7.3
- 4.8.0
- 4.9.0
- 4.9.1
- 4.9.2
- Affected ranges
- ECOSYSTEM: < 4.17.0
Update to 4.17.0
ckeditor Ubuntu:Pro:16.04:LTS
- Versions
- 4.4.4+dfsg1-3
- 4.5.6+dfsg-1
- 4.5.7+dfsg-1
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm1
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm2
- 4.5.7+dfsg-2ubuntu0.16.04.1~esm3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:16.04:LTS
- Versions
- 4.9-1
- 5.1-1
- 5.2-1
- 5.2-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:16.04:LTS
- Versions
- 4.2.11-2
- 4.2.12-3
- 4.2.12-4
- 4.2.12-5
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor Ubuntu:Pro:18.04:LTS
- Versions
- 4.5.7+dfsg-2
- 4.5.7+dfsg-2ubuntu0.18.04.1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm1
- 4.5.7+dfsg-2ubuntu0.18.04.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:18.04:LTS
- Versions
- 3.6.6.1+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:18.04:LTS
- Versions
- 5.7-1
- 6.1-1
- 6.2-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:Pro:18.04:LTS
- Versions
- 4.4.1-5
- 4.4.2-1
- 4.4.2-2
- 4.4.2-2ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor Ubuntu:Pro:20.04:LTS
- Versions
- 4.11.1+dfsg-1
- 4.12.1+dfsg-1
- 4.12.1+dfsg-1ubuntu0.1
- 4.12.1+dfsg-1ubuntu0.1+esm1
- 4.12.1+dfsg-1ubuntu0.1+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:20.04:LTS
- Versions
- 3.6.6.1+dfsg-3
- 3.6.6.1+dfsg-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:20.04:LTS
- Versions
- 6.7-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:20.04:LTS
- Versions
- 4.4.3-2
- 4.4.3-2+deb10u3build0.20.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:22.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:22.04:LTS
- Versions
- 7.5-1
- 7.7-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:22.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu1.22.04.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor Ubuntu:Pro:22.04:LTS
- Versions
- 4.16.0+dfsg-2
- 4.16.2+dfsg-1
- 4.16.2+dfsg-1ubuntu0.1~esm1
- 4.16.2+dfsg-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ckeditor3 Ubuntu:24.04:LTS
- Versions
- 3.6.6.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:24.04:LTS
- Versions
- 8.3-1
- 8.5-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
request-tracker4 Ubuntu:24.04:LTS
- Versions
- 4.4.4+dfsg-2ubuntu1
- 4.4.4+dfsg-2ubuntu2
- 4.4.7+dfsg-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ldap-account-manager Ubuntu:25.10
- Versions
- 9.0-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ckeditor/ckeditor4/blob/major/CHANGES.md#ckeditor-417
- https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-7h26-63m7-qhf2
- https://www.oracle.com/security-alerts/cpujan2022.html
- https://www.drupal.org/sa-core-2021-011
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-41165