CVE-2022-1941
CVE-2022-1941 · Out of Memory issue in ProtocolBuffers for cpp and python
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17 are no longer updated.
CVSS 7.5 · Hoch · EPSS 1,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
protobuf-cpp
- Softwareversionen
- ≥ unspecified, ≤ 3.16.1: Betroffen (custom)
- ≥ unspecified, ≤ 3.17.3: Betroffen (custom)
- ≥ unspecified, ≤ 3.18.2: Betroffen (custom)
- ≥ unspecified, ≤ 3.19.4: Betroffen (custom)
- ≥ unspecified, ≤ 3.20.1: Betroffen (custom)
- ≥ unspecified, ≤ 3.21.5: Betroffen (custom)
Keine Korrektur veröffentlicht
protobuf-python
- Softwareversionen
- ≥ unspecified, ≤ 3.16.1: Betroffen (custom)
- ≥ unspecified, ≤ 3.17.3: Betroffen (custom)
- ≥ unspecified, ≤ 3.18.2: Betroffen (custom)
- ≥ unspecified, ≤ 3.19.4: Betroffen (custom)
- ≥ unspecified, ≤ 3.20.1: Betroffen (custom)
- ≥ unspecified, ≤ 4.21.5: Betroffen (custom)
Keine Korrektur veröffentlicht
protobuf Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.21.9-3
Auf 3.21.9-3 aktualisieren
protobuf Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.21.9-3
Auf 3.21.9-3 aktualisieren
protobuf Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.21.9-3
Auf 3.21.9-3 aktualisieren
protobuf PyPI
- Softwareversionen
- 2.0.0beta
- 2.0.3
- 2.3.0
- 2.4.1
- 2.5.0
- 2.6.0
- 2.6.1
- 3.0.0
- 3.0.0a2
- 3.0.0a3
- 3.0.0b1
- 3.0.0b1.post1
- 3.0.0b1.post2
- 3.0.0b2
- 3.0.0b2.post1
- 3.0.0b2.post2
- 3.0.0b3
- 3.0.0b4
- 3.1.0
- 3.1.0.post1
- 3.10.0
- 3.10.0rc1
- 3.11.0
- 3.11.0rc1
- 3.11.0rc2
- 3.11.1
- 3.11.2
- 3.11.3
- 3.12.0
- 3.12.0rc1
- 3.12.0rc2
- 3.12.1
- 3.12.2
- 3.12.4
- 3.13.0
- 3.13.0rc3
- 3.14.0
- 3.14.0rc1
- 3.14.0rc2
- 3.14.0rc3
- 3.15.0
- 3.15.0rc1
- 3.15.0rc2
- 3.15.1
- 3.15.2
- 3.15.3
- 3.15.4
- 3.15.5
- 3.15.6
- 3.15.7
- 3.15.8
- 3.16.0
- 3.16.0rc1
- 3.16.0rc2
- 3.17.0
- 3.17.0rc1
- 3.17.0rc2
- 3.17.1
- 3.17.2
- 3.17.3
- 3.18.0
- 3.18.0rc1
- 3.18.0rc2
- 3.18.1
- 3.2.0
- 3.2.0rc1
- 3.2.0rc1.post1
- 3.2.0rc2
- 3.3.0
- 3.4.0
- 3.5.0.post1
- 3.5.1
- 3.5.2
- 3.5.2.post1
- 3.6.0
- 3.6.1
- 3.7.0
- 3.7.0rc2
- 3.7.0rc3
- 3.7.1
- 3.8.0
- 3.8.0rc1
- 3.9.0
- 3.9.0rc1
- 3.9.1
- 3.9.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.18.3
Auf 3.18.3 aktualisieren
protobuf PyPI
- Softwareversionen
- 3.19.0
- 3.19.1
- 3.19.2
- 3.19.3
- 3.19.4
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.19.0, < 3.19.5
Auf 3.19.5 aktualisieren
protobuf PyPI
- Softwareversionen
- 3.20.0
- 3.20.1
- 3.20.1rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 3.20.0, < 3.20.2
Auf 3.20.2 aktualisieren
protobuf PyPI
- Softwareversionen
- 4.21.0
- 4.21.0rc1
- 4.21.0rc2
- 4.21.1
- 4.21.2
- 4.21.3
- 4.21.4
- 4.21.5
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.0.0, < 4.21.6
Auf 4.21.6 aktualisieren
protobuf PyPI
- Softwareversionen
- 2.0.0beta
- 2.0.3
- 2.3.0
- 2.4.1
- 2.5.0
- 2.6.0
- 2.6.1
- 3.0.0
- 3.0.0a2
- 3.0.0a3
- 3.0.0b1
- 3.0.0b1.post1
- 3.0.0b1.post2
- 3.0.0b2
- 3.0.0b2.post1
- 3.0.0b2.post2
- 3.0.0b3
- 3.0.0b4
- 3.1.0
- 3.1.0.post1
- 3.10.0
- 3.10.0rc1
- 3.11.0
- 3.11.0rc1
- 3.11.0rc2
- 3.11.1
- 3.11.2
- 3.11.3
- 3.12.0
- 3.12.0rc1
- 3.12.0rc2
- 3.12.1
- 3.12.2
- 3.12.4
- 3.13.0
- 3.13.0rc3
- 3.14.0
- 3.14.0rc1
- 3.14.0rc2
- 3.14.0rc3
- 3.15.0
- 3.15.0rc1
- 3.15.0rc2
- 3.15.1
- 3.15.2
- 3.15.3
- 3.15.4
- 3.15.5
- 3.15.6
- 3.15.7
- 3.15.8
- 3.16.0
- 3.16.0rc1
- 3.16.0rc2
- 3.17.0
- 3.17.0rc1
- 3.17.0rc2
- 3.17.1
- 3.17.2
- 3.17.3
- 3.18.0
- 3.18.0rc1
- 3.18.0rc2
- 3.18.1
- 3.19.0
- 3.19.1
- 3.19.2
- 3.19.3
- 3.19.4
- 3.2.0
- 3.2.0rc1
- 3.2.0rc1.post1
- 3.2.0rc2
- 3.20.0
- 3.20.1
- 3.20.1rc1
- 3.3.0
- 3.4.0
- 3.5.0.post1
- 3.5.1
- 3.5.2
- 3.5.2.post1
- 3.6.0
- 3.6.1
- 3.7.0
- 3.7.0rc2
- 3.7.0rc3
- 3.7.1
- 3.8.0
- 3.8.0rc1
- 3.9.0
- 3.9.0rc1
- 3.9.1
- 3.9.2
- 4.21.0
- 4.21.0rc1
- 4.21.0rc2
- 4.21.1
- 4.21.2
- 4.21.3
- 4.21.4
- 4.21.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.18.3 ∪ ≥ 3.19.0, < 3.19.5 ∪ ≥ 3.20.0, < 3.20.2 ∪ ≥ 4.0.0, < 4.21.6
Auf 3.18.3 aktualisieren; Auf 3.19.5 aktualisieren; Auf 3.20.2 aktualisieren; Auf 4.21.6 aktualisieren
protobuf Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2.4.1-3ubuntu2
- 2.4.1-3ubuntu3
- 2.4.1-3ubuntu4
- 2.5.0-5ubuntu2
- 2.5.0-7ubuntu1
- 2.5.0-8ubuntu1
- 2.5.0-9ubuntu1
- 2.5.0-9ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
protobuf Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.6.1-1.2
- 2.6.1-1.3
- 2.6.1-1.3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.1-1.3ubuntu0.1~esm2
Auf 2.6.1-1.3ubuntu0.1~esm2 aktualisieren
protobuf Ubuntu:18.04:LTS
- Softwareversionen
- 3.0.0-9ubuntu5
- 3.0.0-9ubuntu6
- 3.0.0-9.1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.0-9.1ubuntu1.1
Auf 3.0.0-9.1ubuntu1.1 aktualisieren
protobuf Ubuntu:20.04:LTS
- Softwareversionen
- 3.6.1.3-2
- 3.6.1.3-2ubuntu1
- 3.6.1.3-2ubuntu3
- 3.6.1.3-2ubuntu4
- 3.6.1.3-2ubuntu5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.6.1.3-2ubuntu5.2
Auf 3.6.1.3-2ubuntu5.2 aktualisieren
protobuf Ubuntu:22.04:LTS
- Softwareversionen
- 3.12.4-1ubuntu3
- 3.12.4-1ubuntu5
- 3.12.4-1ubuntu6
- 3.12.4-1ubuntu7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.12.4-1ubuntu7.22.04.1
Auf 3.12.4-1ubuntu7.22.04.1 aktualisieren
Originalquellen
- https://cloud.google.com/support/bulletins#GCP-2022-019
- https://github.com/protocolbuffers/protobuf/security/advisories/GHSA-8gq9-2x98-w8hf
- http://www.openwall.com/lists/oss-security/2022/09/27/1
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CBAUKJQL6O4TIWYBENORSY5P43TVB4M3/
- https://lists.debian.org/debian-lts-announce/2023/04/msg00019.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/MPCGUT3T5L6C3IDWUPSUO22QDCGQKTOP/
- https://security.netapp.com/advisory/ntap-20240705-0001/
- https://nvd.nist.gov/vuln/detail/CVE-2022-1941