p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in protobuf

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für protobuf: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 8

  1. CVE-2026-0994

    Hoch · CVSS 8.2EPSS 0,71%Korrektur verfügbar

    Denial of Service in Python Protobuf

    A denial-of-service (DoS) vulnerability exists in google.protobuf.json_format.ParseDict() in Python, where the max_recursion_depth limit can be bypassed when parsing nested google.protobuf.Any messages. Due to missing recursion depth accounting inside the internal Any-handling logic, an attacker can supply deeply nested Any structures that bypass the intended recursion limit, eventually exhausting Python’s recursion stack and causing a RecursionError.

    • Auf 3.12.4-1ubuntu7.22.04.6 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-4565

    Hoch · CVSS 8.2EPSS 0,26%Korrektur verfügbar

    Unbounded recursion in Python Protobuf

    Any project that uses Protobuf Pure-Python backend to parse untrusted Protocol Buffers data containing an arbitrary number of recursive groups, recursive messages or a series of SGROUP tags can be corrupted by exceeding the Python recursion limit. This can result in a Denial of service by crashing the application with a RecursionError. We recommend upgrading to version =>6.31.1 or beyond commit 17838beda2943d08b8a9d4df5b68f5f04f26d901

    • Auf 3.12.4-1ubuntu7.22.04.4 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2024-7254

    Hoch · CVSS 8.7EPSS 2,77%Korrektur verfügbar

    Stack overflow in Protocol Buffers Java Lite

    Any project that parses untrusted Protocol Buffers data containing an arbitrary number of nested groups / series of SGROUP tags can corrupted by exceeding the stack limit i.e. StackOverflow. Parsing nested groups as unknown fields with DiscardUnknownFieldsParser or Java Protobuf Lite parser, or against Protobuf map fields, creates unbounded recursions that can be abused by an attacker.

    • Auf 3.12.4-1ubuntu7.22.04.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2022-3510

    Hoch · CVSS 7.5EPSS 0,72%Keine Korrektur veröffentlicht

    Parsing issue in protobuf message-type extension

    A parsing issue similar to CVE-2022-3171, but with Message-Type Extensions in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

    Veröffentlicht Aktualisiert
  5. CVE-2022-3171

    Mittel · CVSS 4.3EPSS 1,28%Öffentlicher ExploitKeine Korrektur veröffentlicht

    Memory handling vulnerability in ProtocolBuffers Java core and lite

    A parsing issue with binary data in protobuf-java core and lite versions prior to 3.21.7, 3.20.3, 3.19.6 and 3.16.3 can lead to a denial of service attack. Inputs containing multiple instances of non-repeated embedded messages with repeated or unknown fields causes objects to be converted back-n-forth between mutable and immutable forms, resulting in potentially long garbage collection pauses. We recommend updating to the versions mentioned above.

    Veröffentlicht Aktualisiert
  6. CVE-2022-1941

    Hoch · CVSS 7.5EPSS 1,51%Korrektur verfügbar

    Out of Memory issue in ProtocolBuffers for cpp and python

    A parsing vulnerability for the MessageSet type in the ProtocolBuffers versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 3.21.5 for protobuf-cpp, and versions prior to and including 3.16.1, 3.17.3, 3.18.2, 3.19.4, 3.20.1 and 4.21.5 for protobuf-python can lead to out of memory failures. A specially crafted message with multiple key-value per elements creates parsing issues, and can lead to a Denial of Service against services receiving unsanitized input. We recommend upgrading to versions 3.18.3, 3.19.5, 3.20.2, 3.21.6 for protobuf-cpp and 3.18.3, 3.19.5, 3.20.2, 4.21.6 for protobuf-python. Versions for 3.16 and 3.17

    • Auf 3.12.4-1ubuntu7.22.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  7. CVE-2021-22570

    Mittel · CVSS 6.5EPSS 2,66%Korrektur verfügbar

    Nullptr Dereference in Protobuf

    Nullptr dereference when a null char is present in a proto symbol. The symbol is parsed incorrectly, leading to an unchecked call into the proto file's name during generation of the resulting error message. Since the symbol is incorrectly parsed, the file is nullptr. We recommend upgrading to version 3.15.0 or greater.

    • Auf 3.12.4-1ubuntu7.22.04.1 aktualisieren
    Veröffentlicht Aktualisiert
  8. CVE-2021-22569

    Hoch · CVSS 7.5EPSS 1,8%Korrektur verfügbar

    Denial of Service of protobuf-java parsing procedure

    An issue in protobuf-java allowed the interleaving of com.google.protobuf.UnknownFieldSet fields in such a way that would be processed out of order. A small malicious payload can occupy the parser for several minutes by creating large numbers of short-lived objects that cause frequent, repeated pauses. We recommend upgrading libraries beyond the vulnerable versions.

    • Auf 3.12.4-1ubuntu7.22.04.1 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →