p PatchFirst

CVE-2022-24833

CVE-2022-24833 · Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.

CVSS 8.2 · Hoch · EPSS 1,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • privatebin

    Softwareversionen
    • >= v0.21, < v1.4.0: Betroffen

    Keine Korrektur veröffentlicht

  • privatebin/privatebin Packagist

    Softwareversionen
    • 1.0
    • 1.1
    • 1.1.1
    • 1.2
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.3
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.3.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.21, < 1.4.0

    Auf 1.4.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →