CVE-2022-24833
CVE-2022-24833 · Persistent Cross-site Scripting (XSS) vulnerability in PrivateBin
This page contains facts from public vulnerability sources. Check the original advisory before updating.
PrivateBin is minimalist, open source online pastebin clone where the server has zero knowledge of pasted data. In PrivateBin < v1.4.0 a cross-site scripting (XSS) vulnerability was found. The vulnerability is present in all versions from v0.21 of the project, which was at the time still called ZeroBin. The issue is caused by the fact that SVGs can contain JavaScript. This can allow an attacker to execute code, if the user opens a paste with a specifically crafted SVG attachment, and interacts with the preview image and the instance isn't protected by an appropriate content security policy. Users are advised to either upgrade to version 1.4.0 or to ensure the content security policy of their instance is set correctly.
CVSS 8.2 · High · EPSS 1.4% · Fix available
- Published
- Updated
Stack: php
Affected products and versions
privatebin
- Versions
- >= v0.21, < v1.4.0: Affected
No fix published
privatebin/privatebin Packagist
- Versions
- 1.0
- 1.1
- 1.1.1
- 1.2
- 1.2.1
- 1.2.2
- 1.2.3
- 1.3
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- Affected ranges
- ECOSYSTEM: ≥ 0.21, < 1.4.0
Update to 1.4.0