p PatchFirst

CVE-2022-31117

CVE-2022-31117 · Double free of buffer during string decoding in ujson

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. In versions prior to 5.4.0 an error occurring while reallocating a buffer for string decoding can cause the buffer to get freed twice. Due to how UltraJSON uses the internal decoder, this double free is impossible to trigger from Python. This issue has been resolved in version 5.4.0 and all users should upgrade to UltraJSON 5.4.0. There are no known workarounds for this issue.

CVSS 5.9 · Mittel · EPSS 1,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • ultrajson

    Softwareversionen
    • < 5.4.0: Betroffen

    Keine Korrektur veröffentlicht

  • ujson Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.0-1

    Auf 5.4.0-1 aktualisieren

  • ujson Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.0-1

    Auf 5.4.0-1 aktualisieren

  • ujson Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.0-1

    Auf 5.4.0-1 aktualisieren

  • ujson PyPI

    Softwareversionen
    • 1.15
    • 1.18
    • 1.19
    • 1.21
    • 1.22
    • 1.23
    • 1.30
    • 1.33
    • 1.34
    • 1.35
    • 1.4
    • 1.6
    • 1.8
    • 1.9
    • 2.0.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 3.0.0
    • 3.1.0
    • 3.2.0
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.1.0
    • 4.2.0
    • 4.3.0
    • 5.0.0
    • 5.1.0
    • 5.2.0
    • 5.3.0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.4.0

    Auf 5.4.0 aktualisieren

  • pandas Ubuntu:14.04:LTS

    Softwareversionen
    • 0.12.0-2ubuntu1
    • 0.13.1-2ubuntu1
    • 0.13.1-2ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ujson Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.33-1
    • 1.33-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.33-1ubuntu0.1~esm2

    Auf 1.33-1ubuntu0.1~esm2 aktualisieren

  • collada2gltf Ubuntu:16.04:LTS

    Softwareversionen
    • 20140924-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:16.04:LTS

    Softwareversionen
    • 0.15.0-2
    • 0.15.0-2ubuntu1
    • 0.15.0-2ubuntu2
    • 0.17.1-3ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • collada2gltf Ubuntu:18.04:LTS

    Softwareversionen
    • 20140924-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:18.04:LTS

    Softwareversionen
    • 0.19.2-5.1ubuntu4
    • 0.22.0-2ubuntu1
    • 0.22.0-3
    • 0.22.0-4
    • 0.22.0-4ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ujson Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.35-1build2
    • 1.35-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.35-2ubuntu0.1~esm1

    Auf 1.35-2ubuntu0.1~esm1 aktualisieren

  • pandas Ubuntu:20.04:LTS

    Softwareversionen
    • 0.23.3+dfsg-4ubuntu1
    • 0.23.3+dfsg-4ubuntu5
    • 0.23.3+dfsg-4ubuntu6
    • 0.25.3+dfsg-4
    • 0.25.3+dfsg-4build1
    • 0.25.3+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • collada2gltf Ubuntu:22.04:LTS

    Softwareversionen
    • 20140924-7build1
    • 20140924-8
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:22.04:LTS

    Softwareversionen
    • 1.1.5+dfsg-2
    • 1.1.5+dfsg-2ubuntu1
    • 1.3.5+dfsg-2
    • 1.3.5+dfsg-2ubuntu1
    • 1.3.5+dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ujson Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 4.0.2-1
    • 4.0.2-1build1
    • 4.2.0-1
    • 5.1.0-1
    • 5.1.0-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.1.0-1ubuntu0.1~esm1

    Auf 5.1.0-1ubuntu0.1~esm1 aktualisieren

  • pandas Ubuntu:24.04:LTS

    Softwareversionen
    • 1.5.3+dfsg-6
    • 1.5.3+dfsg-6ubuntu1
    • 1.5.3+dfsg-7ubuntu1
    • 1.5.3+dfsg-10
    • 2.1.4+dfsg-4ubuntu2
    • 2.1.4+dfsg-7
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:25.10

    Softwareversionen
    • 2.2.3+dfsg-8build1
    • 2.2.3+dfsg-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:26.10

    Softwareversionen
    • 2.3.3+dfsg-3ubuntu1
    • 2.3.3+dfsg-3ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • pandas Ubuntu:26.04:LTS

    Softwareversionen
    • 2.2.3+dfsg-9
    • 2.3.3+dfsg-1ubuntu1
    • 2.3.3+dfsg-3
    • 2.3.3+dfsg-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →