CVE-2022-31117
CVE-2022-31117 · Double free of buffer during string decoding in ujson
This page contains facts from public vulnerability sources. Check the original advisory before updating.
UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. In versions prior to 5.4.0 an error occurring while reallocating a buffer for string decoding can cause the buffer to get freed twice. Due to how UltraJSON uses the internal decoder, this double free is impossible to trigger from Python. This issue has been resolved in version 5.4.0 and all users should upgrade to UltraJSON 5.4.0. There are no known workarounds for this issue.
CVSS 5.9 · Medium · EPSS 1.9% · Fix available
- Published
- Updated
Affected products and versions
ultrajson
- Versions
- < 5.4.0: Affected
No fix published
ujson Debian:12
- Affected ranges
- ECOSYSTEM: < 5.4.0-1
Update to 5.4.0-1
ujson Debian:13
- Affected ranges
- ECOSYSTEM: < 5.4.0-1
Update to 5.4.0-1
ujson Debian:14
- Affected ranges
- ECOSYSTEM: < 5.4.0-1
Update to 5.4.0-1
ujson PyPI
- Versions
- 1.15
- 1.18
- 1.19
- 1.21
- 1.22
- 1.23
- 1.30
- 1.33
- 1.34
- 1.35
- 1.4
- 1.6
- 1.8
- 1.9
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 3.0.0
- 3.1.0
- 3.2.0
- 4.0.0
- 4.0.1
- 4.0.2
- 4.1.0
- 4.2.0
- 4.3.0
- 5.0.0
- 5.1.0
- 5.2.0
- 5.3.0
- Affected ranges
- ECOSYSTEM: < 5.4.0
Update to 5.4.0
pandas Ubuntu:14.04:LTS
- Versions
- 0.12.0-2ubuntu1
- 0.13.1-2ubuntu1
- 0.13.1-2ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ujson Ubuntu:Pro:16.04:LTS
- Versions
- 1.33-1
- 1.33-1build1
- Affected ranges
- ECOSYSTEM: < 1.33-1ubuntu0.1~esm2
Update to 1.33-1ubuntu0.1~esm2
collada2gltf Ubuntu:16.04:LTS
- Versions
- 20140924-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:16.04:LTS
- Versions
- 0.15.0-2
- 0.15.0-2ubuntu1
- 0.15.0-2ubuntu2
- 0.17.1-3ubuntu2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
collada2gltf Ubuntu:18.04:LTS
- Versions
- 20140924-4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:18.04:LTS
- Versions
- 0.19.2-5.1ubuntu4
- 0.22.0-2ubuntu1
- 0.22.0-3
- 0.22.0-4
- 0.22.0-4ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ujson Ubuntu:Pro:18.04:LTS
- Versions
- 1.35-1build2
- 1.35-2
- Affected ranges
- ECOSYSTEM: < 1.35-2ubuntu0.1~esm1
Update to 1.35-2ubuntu0.1~esm1
pandas Ubuntu:20.04:LTS
- Versions
- 0.23.3+dfsg-4ubuntu1
- 0.23.3+dfsg-4ubuntu5
- 0.23.3+dfsg-4ubuntu6
- 0.25.3+dfsg-4
- 0.25.3+dfsg-4build1
- 0.25.3+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
collada2gltf Ubuntu:22.04:LTS
- Versions
- 20140924-7build1
- 20140924-8
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:22.04:LTS
- Versions
- 1.1.5+dfsg-2
- 1.1.5+dfsg-2ubuntu1
- 1.3.5+dfsg-2
- 1.3.5+dfsg-2ubuntu1
- 1.3.5+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
ujson Ubuntu:Pro:22.04:LTS
- Versions
- 4.0.2-1
- 4.0.2-1build1
- 4.2.0-1
- 5.1.0-1
- 5.1.0-1build1
- Affected ranges
- ECOSYSTEM: < 5.1.0-1ubuntu0.1~esm1
Update to 5.1.0-1ubuntu0.1~esm1
pandas Ubuntu:24.04:LTS
- Versions
- 1.5.3+dfsg-6
- 1.5.3+dfsg-6ubuntu1
- 1.5.3+dfsg-7ubuntu1
- 1.5.3+dfsg-10
- 2.1.4+dfsg-4ubuntu2
- 2.1.4+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:25.10
- Versions
- 2.2.3+dfsg-8build1
- 2.2.3+dfsg-9
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:26.10
- Versions
- 2.3.3+dfsg-3ubuntu1
- 2.3.3+dfsg-3ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
pandas Ubuntu:26.04:LTS
- Versions
- 2.2.3+dfsg-9
- 2.3.3+dfsg-1ubuntu1
- 2.3.3+dfsg-3
- 2.3.3+dfsg-3ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
Original sources
- https://github.com/ultrajson/ultrajson/security/advisories/GHSA-fm67-cv37-96ff
- https://github.com/ultrajson/ultrajson/commit/9c20de0f77b391093967e25d01fb48671104b15b
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/OPPU5FZP3LCTXYORFH7NHUMYA5X66IA7/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/NAU5N4A7EUK2AMUCOLYDD5ARXAJYZBD2/
- https://nvd.nist.gov/vuln/detail/CVE-2022-31117