CVE-2023-25156
CVE-2023-25156 · Kiwi TCMS has no protection against brute-force attacks on login page
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Kiwi TCMS, an open source test management system, does not impose rate limits in versions prior to 12.0. This makes it easier to attempt brute-force attacks against the login page. Users should upgrade to v12.0 or later to receive a patch. As a workaround, users may install and configure a rate-limiting proxy in front of Kiwi TCMS.
CVSS 7.5 · Hoch · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
kiwi
- Softwareversionen
- ≥ 12.0, < 12.0: Betroffen (custom)
Keine Korrektur veröffentlicht
kiwitcms PyPI
- Softwareversionen
- 10.0
- 10.1
- 10.2
- 10.3
- 10.3.999
- 10.4
- 10.5
- 11.0
- 11.1
- 11.3
- 11.4
- 11.5
- 11.6
- 11.7
- 6.10
- 6.11
- 6.2.1
- 6.3
- 6.4
- 6.5
- 6.5.3
- 6.6
- 6.7
- 6.8
- 6.9
- 7.0
- 7.1
- 7.2
- 7.2.1
- 7.3
- 8.0
- 8.1
- 8.1.99
- 8.2
- 8.3
- 8.4
- 8.5
- 8.6
- 8.6.1
- 8.7
- 8.8
- 8.9
- 9.0
- 9.999
- Betroffene Versionsbereiche
- ECOSYSTEM: < 12.0
Auf 12.0 aktualisieren
Originalquellen
- https://huntr.dev/bounties/2b1a9be9-45e9-490b-8de0-26a492e79795/
- https://kiwitcms.org/blog/kiwi-tcms-team/2023/02/15/kiwi-tcms-120/
- https://github.com/kiwitcms/Kiwi/security/advisories/GHSA-7968-h4m4-ghm9
- https://github.com/kiwitcms/Kiwi/commit/0ed213fa0ddb7a6dc77e3c3b99e8fc90ccdaf46f
- https://nvd.nist.gov/vuln/detail/CVE-2023-25156