p PatchFirst

CVE-2023-25156

CVE-2023-25156 · Kiwi TCMS has no protection against brute-force attacks on login page

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Kiwi TCMS, an open source test management system, does not impose rate limits in versions prior to 12.0. This makes it easier to attempt brute-force attacks against the login page. Users should upgrade to v12.0 or later to receive a patch. As a workaround, users may install and configure a rate-limiting proxy in front of Kiwi TCMS.

CVSS 7.5 · High · EPSS 0.9% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • kiwi

    Versions
    • ≥ 12.0, < 12.0: Affected (custom)

    No fix published

  • kiwitcms PyPI

    Versions
    • 10.0
    • 10.1
    • 10.2
    • 10.3
    • 10.3.999
    • 10.4
    • 10.5
    • 11.0
    • 11.1
    • 11.3
    • 11.4
    • 11.5
    • 11.6
    • 11.7
    • 6.10
    • 6.11
    • 6.2.1
    • 6.3
    • 6.4
    • 6.5
    • 6.5.3
    • 6.6
    • 6.7
    • 6.8
    • 6.9
    • 7.0
    • 7.1
    • 7.2
    • 7.2.1
    • 7.3
    • 8.0
    • 8.1
    • 8.1.99
    • 8.2
    • 8.3
    • 8.4
    • 8.5
    • 8.6
    • 8.6.1
    • 8.7
    • 8.8
    • 8.9
    • 9.0
    • 9.999
    Affected ranges
    • ECOSYSTEM: < 12.0

    Update to 12.0

Original sources

Check your server →