CVE-2023-25725
CVE-2023-25725
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
HAProxy before 2.7.3 may allow a bypass of access control because HTTP/1 headers are inadvertently lost in some situations, aka "request smuggling." The HTTP header parsers in HAProxy may accept empty header field names, which could be used to truncate the list of HTTP headers and thus make some headers disappear after being parsed and processed for HTTP/1.0 and HTTP/1.1. For HTTP/2 and HTTP/3, the impact is limited because the headers disappear before being parsed and processed, as if they had not been sent by the client. The fixed versions are 2.7.3, 2.6.9, 2.5.12, 2.4.22, 2.2.29, and 2.0.31.
CVSS 9.1 · Kritisch · EPSS 5,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · web
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
haproxy Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.8-2
Auf 2.6.8-2 aktualisieren
haproxy Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.8-2
Auf 2.6.8-2 aktualisieren
haproxy Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.8-2
Auf 2.6.8-2 aktualisieren
haproxy Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.5.14-1
- 1.5.15-1
- 1.6.2-1
- 1.6.2-2
- 1.6.2-2ubuntu1
- 1.6.2-2ubuntu3
- 1.6.3-1
- 1.6.3-1ubuntu0.1
- 1.6.3-1ubuntu0.2
- 1.6.3-1ubuntu0.3
- 1.6.3-1ubuntu0.3+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.3-1ubuntu0.3+esm2
Auf 1.6.3-1ubuntu0.3+esm2 aktualisieren
haproxy Ubuntu:18.04:LTS
- Softwareversionen
- 1.7.9-1ubuntu1
- 1.7.9-1ubuntu2
- 1.8.4-1
- 1.8.7-1
- 1.8.8-1
- 1.8.8-1ubuntu0.1
- 1.8.8-1ubuntu0.2
- 1.8.8-1ubuntu0.3
- 1.8.8-1ubuntu0.4
- 1.8.8-1ubuntu0.6
- 1.8.8-1ubuntu0.7
- 1.8.8-1ubuntu0.8
- 1.8.8-1ubuntu0.9
- 1.8.8-1ubuntu0.10
- 1.8.8-1ubuntu0.11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.8.8-1ubuntu0.13
Auf 1.8.8-1ubuntu0.13 aktualisieren
haproxy Ubuntu:20.04:LTS
- Softwareversionen
- 2.0.5-1
- 2.0.8-1
- 2.0.9-1
- 2.0.10-1
- 2.0.10-1ubuntu1
- 2.0.11-1ubuntu1
- 2.0.12-1ubuntu2
- 2.0.13-1ubuntu2
- 2.0.13-2
- 2.0.13-2ubuntu0.1
- 2.0.13-2ubuntu0.2
- 2.0.13-2ubuntu0.3
- 2.0.13-2ubuntu0.5
- 2.0.29-0ubuntu1
- 2.0.29-0ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.29-0ubuntu1.3
Auf 2.0.29-0ubuntu1.3 aktualisieren
haproxy Ubuntu:22.04:LTS
- Softwareversionen
- 2.2.9-2ubuntu2
- 2.4.8-1
- 2.4.8-2ubuntu3
- 2.4.11-1ubuntu1
- 2.4.12-1ubuntu1
- 2.4.12-1ubuntu2
- 2.4.13-1ubuntu1
- 2.4.14-1ubuntu1
- 2.4.18-0ubuntu1
- 2.4.18-0ubuntu1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.18-0ubuntu1.2
Auf 2.4.18-0ubuntu1.2 aktualisieren
Originalquellen
- https://www.haproxy.org/
- https://git.haproxy.org/?p=haproxy-2.7.git%3Ba=commit%3Bh=a0e561ad7f29ed50c473f5a9da664267b60d1112
- https://lists.debian.org/debian-lts-announce/2023/02/msg00012.html
- https://www.debian.org/security/2023/dsa-5348
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FPTJQHKUEU2PQ7RWFUYAFLAD4STEIKHU/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/JM5NCIBTHYDTLPY2UNC4HO2VAHHE6CJG/
- https://nvd.nist.gov/vuln/detail/CVE-2023-25725