p PatchFirst

CVE-2023-27598

CVE-2023-27598 · OpenSIPS has vulnerability in the parse_via() function

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, sending a malformed `Via` header to OpenSIPS triggers a segmentation fault when the function `calc_tag_suffix` is called. A specially crafted `Via` header, which is deemed correct by the parser, will pass uninitialized strings to the function `MD5StringArray` which leads to the crash. Abuse of this vulnerability leads to Denial of Service due to a crash. Since the uninitialized string points to memory location `0x0`, no further exploitation appears to be possible. No special network privileges are required to perform this attack, as long as the OpenSIPS configuration makes use of functions such as `sl_send_reply` or `sl_gen_totag` that trigger the vulnerable code. This issue has been fixed in versions 3.1.7 and 3.2.4.

CVSS 7.5 · Hoch · EPSS 1,0%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • opensips

    Softwareversionen
    • < 3.1.7: Betroffen
    • >= 3.2.0, < 3.2.4: Betroffen

    Keine Korrektur veröffentlicht

  • opensips Ubuntu:18.04:LTS

    Softwareversionen
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →