p PatchFirst

CVE-2023-27598

CVE-2023-27598 · OpenSIPS has vulnerability in the parse_via() function

This page contains facts from public vulnerability sources. Check the original advisory before updating.

OpenSIPS is a Session Initiation Protocol (SIP) server implementation. Prior to versions 3.1.7 and 3.2.4, sending a malformed `Via` header to OpenSIPS triggers a segmentation fault when the function `calc_tag_suffix` is called. A specially crafted `Via` header, which is deemed correct by the parser, will pass uninitialized strings to the function `MD5StringArray` which leads to the crash. Abuse of this vulnerability leads to Denial of Service due to a crash. Since the uninitialized string points to memory location `0x0`, no further exploitation appears to be possible. No special network privileges are required to perform this attack, as long as the OpenSIPS configuration makes use of functions such as `sl_send_reply` or `sl_gen_totag` that trigger the vulnerable code. This issue has been fixed in versions 3.1.7 and 3.2.4.

CVSS 7.5 · High · EPSS 1.0%

Published
Updated

Stack: system

Affected products and versions

  • opensips

    Versions
    • < 3.1.7: Affected
    • >= 3.2.0, < 3.2.4: Affected

    No fix published

  • opensips Ubuntu:18.04:LTS

    Versions
    • 2.2.2-3build2
    • 2.2.2-3build3
    • 2.2.2-3build4
    Affected ranges
    • ECOSYSTEM: (−∞, +∞)

    No fix published

Original sources

Check your server →