p PatchFirst

CVE-2023-28115

CVE-2023-28115 · Snappy vulnerable to PHAR deserialization, allowing remote code execution

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Snappy is a PHP library allowing thumbnail, snapshot or PDF generation from a url or a html page. Prior to version 1.4.2, Snappy is vulnerable to PHAR deserialization due to a lack of checking on the protocol before passing it into the `file_exists()` function. If an attacker can upload files of any type to the server he can pass in the phar:// protocol to unserialize the uploaded file and instantiate arbitrary PHP objects. This can lead to remote code execution especially when snappy is used with frameworks with documented POP chains like Laravel/Symfony vulnerable developer code. If a user can control the output file from the `generateFromHtml()` function, it will invoke deserialization. This vulnerability is capable of remote code execution if Snappy is used with frameworks or developer code with vulnerable POP chains. It has been fixed in version 1.4.2.

CVSS 9.8 · Kritisch · EPSS 2,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • snappy

    Softwareversionen
    • < 1.4.2: Betroffen

    Keine Korrektur veröffentlicht

  • civicrm Debian:11

    Softwareversionen
    • 5.33.2+dfsg1-1
    • 5.50.1+dfsg1-1
    • 5.50.3+dfsg1-1
    • 5.52.2+dfsg1-1
    • 5.53.0+dfsg1-1
    • 5.68.1+dfsg1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • knplabs/knp-snappy Packagist

    Softwareversionen
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.2.0
    • 0.2.1
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.4
    • 0.4.1
    • 0.4.2
    • 0.4.3
    • v0.5.0
    • v1.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.2.0
    • v1.2.1
    • v1.3.0
    • v1.3.1
    • v1.4.0
    • v1.4.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.4.2

    Auf 1.4.2 aktualisieren

  • civicrm Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 4.7.1+dfsg-1
    • 4.7.1+dfsg-2
    • 4.7.1+dfsg-2ubuntu1
    • 4.7.1+dfsg-2ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • civicrm Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 4.7.23+dfsg-1ubuntu1
    • 4.7.24+dfsg-1ubuntu1
    • 4.7.30+dfsg-1ubuntu1
    • 4.7.30+dfsg-1ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • civicrm Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 5.11.0+dfsg-1
    • 5.18.1+dfsg-1
    • 5.20.3+dfsg-1
    • 5.21.0+dfsg-1
    • 5.21.1+dfsg-1
    • 5.21.2+dfsg-1
    • 5.21.2+dfsg-1ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • civicrm Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 5.33.2+dfsg1-1
    • 5.33.2+dfsg1-1build1
    • 5.33.2+dfsg1-1ubuntu1
    • 5.33.2+dfsg1-1ubuntu1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →