CVE-2023-5631
CVE-2023-5631 · Stored XSS vulnerability in Roundcube
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker to load arbitrary JavaScript code.
CVSS 6.1 · Mittel · EPSS 76,9% · Im KEV-Katalog · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
roundcubemail
- Softwareversionen
- ≥ 1.6.0, < 1.6.3: Betroffen (semver)
- ≥ 1.5.0, < 1.5.4: Betroffen (semver)
- ≥ 1.4.0, < 1.5.14: Betroffen (semver)
- 1.6.4: Nicht betroffen
- 1.5.5: Nicht betroffen
- 1.5.15: Nicht betroffen
Auf 1.5.5 aktualisieren; Auf 1.6.3 aktualisieren
roundcube Debian:12
- Softwareversionen
- 1.6.1+dfsg-1
- 1.6.2+dfsg-1
- 1.6.3+dfsg-1
- 1.6.3+dfsg-1~deb12u1
- 1.6.3+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.4+dfsg-1~deb12u1
Auf 1.6.4+dfsg-1~deb12u1 aktualisieren
roundcube Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.4+dfsg-1
Auf 1.6.4+dfsg-1 aktualisieren
roundcube Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.4+dfsg-1
Auf 1.6.4+dfsg-1 aktualisieren
roundcube Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.3.0+dfsg.1-1
- 1.3.1+dfsg.1-1
- 1.3.3+dfsg.1-1
- 1.3.3+dfsg.1-2
- 1.3.6+dfsg.1-1
- 1.3.6+dfsg.1-1ubuntu0.1~esm1
- 1.3.6+dfsg.1-1ubuntu0.1~esm2
- 1.3.6+dfsg.1-1ubuntu0.1~esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.3.6+dfsg.1-1ubuntu0.1~esm4
Auf 1.3.6+dfsg.1-1ubuntu0.1~esm4 aktualisieren
roundcube Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.3.8+dfsg.1-2
- 1.3.10+dfsg.1-1
- 1.4.1+dfsg.1-2
- 1.4.2+dfsg.1-1
- 1.4.2+dfsg.1-2
- 1.4.3+dfsg.1-1
- 1.4.3+dfsg.1-1ubuntu0.1~esm1
- 1.4.3+dfsg.1-1ubuntu0.1~esm2
- 1.4.3+dfsg.1-1ubuntu0.1~esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.4.3+dfsg.1-1ubuntu0.1~esm4
Auf 1.4.3+dfsg.1-1ubuntu0.1~esm4 aktualisieren
roundcube Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1.4.11+dfsg.1-4
- 1.5.0+dfsg.1-2
- 1.5.0+dfsg.1-2ubuntu0.1~esm1
- 1.5.0+dfsg.1-2ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.5.0+dfsg.1-2ubuntu0.1~esm3
Auf 1.5.0+dfsg.1-2ubuntu0.1~esm3 aktualisieren
Originalquellen
- https://github.com/roundcube/roundcubemail/commit/6ee6e7ae301e165e2b2cb703edf75552e5376613
- https://github.com/roundcube/roundcubemail/releases/tag/1.6.4
- https://github.com/roundcube/roundcubemail/releases/tag/1.5.5
- https://github.com/roundcube/roundcubemail/releases/tag/1.4.15
- https://github.com/roundcube/roundcubemail/issues/9168
- https://roundcube.net/news/2023/10/16/security-update-1.6.4-released
- https://github.com/roundcube/roundcubemail/commit/41756cc3331b495cc0b71886984474dc529dd31d
- https://roundcube.net/news/2023/10/16/security-updates-1.5.5-and-1.4.15
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1054079
- https://www.debian.org/security/2023/dsa-5531
- https://lists.debian.org/debian-lts-announce/2023/10/msg00035.html
- http://www.openwall.com/lists/oss-security/2023/11/01/1
- http://www.openwall.com/lists/oss-security/2023/11/01/3
- https://lists.fedoraproject.org/archives/list/[email protected]/message/LK67Q46OIEGJCRQUBHKLH3IIJTBNGGX4/
- http://www.openwall.com/lists/oss-security/2023/11/17/2
- https://www.cisa.gov/known-exploited-vulnerabilities-catalog?field_cve=CVE-2023-5631
- https://nvd.nist.gov/vuln/detail/CVE-2023-5631