p PatchFirst

CVE-2023-5631

CVE-2023-5631 · Stored XSS vulnerability in Roundcube

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Roundcube before 1.4.15, 1.5.x before 1.5.5, and 1.6.x before 1.6.4 allows stored XSS via an HTML e-mail message with a crafted SVG document because of program/lib/Roundcube/rcube_washtml.php behavior. This could allow a remote attacker to load arbitrary JavaScript code.

CVSS 6.1 · Medium · EPSS 76.9% · In KEV · Fix available

Published
Updated

Stack: system

Affected products and versions

  • roundcubemail

    Versions
    • ≥ 1.6.0, < 1.6.3: Affected (semver)
    • ≥ 1.5.0, < 1.5.4: Affected (semver)
    • ≥ 1.4.0, < 1.5.14: Affected (semver)
    • 1.6.4: Not affected
    • 1.5.5: Not affected
    • 1.5.15: Not affected

    Update to 1.5.5; Update to 1.6.3

  • roundcube Debian:12

    Versions
    • 1.6.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.3+dfsg-1
    • 1.6.3+dfsg-1~deb12u1
    • 1.6.3+dfsg-2
    Affected ranges
    • ECOSYSTEM: < 1.6.4+dfsg-1~deb12u1

    Update to 1.6.4+dfsg-1~deb12u1

  • roundcube Debian:13

    Affected ranges
    • ECOSYSTEM: < 1.6.4+dfsg-1

    Update to 1.6.4+dfsg-1

  • roundcube Debian:14

    Affected ranges
    • ECOSYSTEM: < 1.6.4+dfsg-1

    Update to 1.6.4+dfsg-1

  • roundcube Ubuntu:Pro:18.04:LTS

    Versions
    • 1.3.0+dfsg.1-1
    • 1.3.1+dfsg.1-1
    • 1.3.3+dfsg.1-1
    • 1.3.3+dfsg.1-2
    • 1.3.6+dfsg.1-1
    • 1.3.6+dfsg.1-1ubuntu0.1~esm1
    • 1.3.6+dfsg.1-1ubuntu0.1~esm2
    • 1.3.6+dfsg.1-1ubuntu0.1~esm3
    Affected ranges
    • ECOSYSTEM: < 1.3.6+dfsg.1-1ubuntu0.1~esm4

    Update to 1.3.6+dfsg.1-1ubuntu0.1~esm4

  • roundcube Ubuntu:Pro:20.04:LTS

    Versions
    • 1.3.8+dfsg.1-2
    • 1.3.10+dfsg.1-1
    • 1.4.1+dfsg.1-2
    • 1.4.2+dfsg.1-1
    • 1.4.2+dfsg.1-2
    • 1.4.3+dfsg.1-1
    • 1.4.3+dfsg.1-1ubuntu0.1~esm1
    • 1.4.3+dfsg.1-1ubuntu0.1~esm2
    • 1.4.3+dfsg.1-1ubuntu0.1~esm3
    Affected ranges
    • ECOSYSTEM: < 1.4.3+dfsg.1-1ubuntu0.1~esm4

    Update to 1.4.3+dfsg.1-1ubuntu0.1~esm4

  • roundcube Ubuntu:Pro:22.04:LTS

    Versions
    • 1.4.11+dfsg.1-4
    • 1.5.0+dfsg.1-2
    • 1.5.0+dfsg.1-2ubuntu0.1~esm1
    • 1.5.0+dfsg.1-2ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: < 1.5.0+dfsg.1-2ubuntu0.1~esm3

    Update to 1.5.0+dfsg.1-2ubuntu0.1~esm3

Original sources

Check your server →