p PatchFirst

CVE-2023-7158

CVE-2023-7158 · MicroPython objslice.c slice_indices heap-based overflow

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was found in MicroPython up to 1.21.0. It has been classified as critical. Affected is the function slice_indices of the file objslice.c. The manipulation leads to heap-based buffer overflow. It is possible to launch the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.22.0 is able to address this issue. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-249180.

CVSS 7.3 · Hoch · EPSS 1,2%

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • micropython

    Softwareversionen
    • 1.13.0: Betroffen
    • 1.14.0: Betroffen
    • 1.15.0: Betroffen
    • 1.16.0: Betroffen
    • 1.17.0: Betroffen
    • 1.18.0: Betroffen
    • 1.19.0: Betroffen
    • 1.20.0: Betroffen
    • 1.21.0: Betroffen

    Keine Korrektur veröffentlicht

  • giac Ubuntu:18.04:LTS

    Softwareversionen
    • 1.2.3.57+dfsg1-2build1
    • 1.2.3.57+dfsg1-2build2
    • 1.2.3.57+dfsg1-2build3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:20.04:LTS

    Softwareversionen
    • 1.4.9.69+dfsg1-2build1
    • 1.5.0.85+dfsg1-2
    • 1.5.0.85+dfsg1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:22.04:LTS

    Softwareversionen
    • 1.6.0.41+dfsg1-1
    • 1.7.0.39+dfsg2-1build1
    • 1.7.0.39+dfsg2-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:24.04:LTS

    Softwareversionen
    • 1.9.0.35+dfsg2-1.1
    • 1.9.0.59+dfsg2-1
    • 1.9.0.69+dfsg2-1
    • 1.9.0.93+dfsg2-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:25.10

    Softwareversionen
    • 1.9.0.93+dfsg2-3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:26.10

    Softwareversionen
    • 1.9.0.93+dfsg2-3build2
    • 1.9.0.93+dfsg2-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • giac Ubuntu:26.04:LTS

    Softwareversionen
    • 1.9.0.93+dfsg2-3build1
    • 1.9.0.93+dfsg2-3build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →