CVE-2024-12909
CVE-2024-12909 · SQL Injection to RCE in run-llama/llama_index
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, allows for SQL injection in the `run_sql_query` function of the `database_agent`. This vulnerability can be exploited by an attacker to inject arbitrary SQL queries, leading to remote code execution (RCE) through the use of PostgreSQL's large object functionality. The issue is fixed in version 0.3.0.
CVSS 10.0 · Kritisch · EPSS 1,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
run-llama/llama_index
- Softwareversionen
- ≥ unspecified, < 0.3.0: Betroffen (custom)
Auf 0.3.0 aktualisieren
llama-index-packs-finchat PyPI
- Softwareversionen
- 0.1.0
- 0.1.1
- 0.2.0
- 0.3.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≤ 0.3.0
Keine Korrektur veröffentlicht