CVE-2024-12909
CVE-2024-12909 · SQL Injection to RCE in run-llama/llama_index
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A vulnerability in the FinanceChatLlamaPack of the run-llama/llama_index repository, versions up to v0.12.3, allows for SQL injection in the `run_sql_query` function of the `database_agent`. This vulnerability can be exploited by an attacker to inject arbitrary SQL queries, leading to remote code execution (RCE) through the use of PostgreSQL's large object functionality. The issue is fixed in version 0.3.0.
CVSS 10.0 · Critical · EPSS 1.4% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
run-llama/llama_index
- Versions
- ≥ unspecified, < 0.3.0: Affected (custom)
Update to 0.3.0
llama-index-packs-finchat PyPI
- Versions
- 0.1.0
- 0.1.1
- 0.2.0
- 0.3.0
- Affected ranges
- ECOSYSTEM: ≤ 0.3.0
No fix published