p PatchFirst

CVE-2024-31210

CVE-2024-31210 · PHP file upload bypass via Plugin installer

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

WordPress is an open publishing platform for the Web. It's possible for a file of a type other than a zip file to be submitted as a new plugin by an administrative user on the Plugins -> Add New -> Upload Plugin screen in WordPress. If FTP credentials are requested for installation (in order to move the file into place outside of the `uploads` directory) then the uploaded file remains temporary available in the Media Library despite it not being allowed. If the `DISALLOW_FILE_EDIT` constant is set to `true` on the site _and_ FTP credentials are required when uploading a new theme or plugin, then this technically allows an RCE when the user would otherwise have no means of executing arbitrary PHP code. This issue _only_ affects Administrator level users on single site installations, and Super Admin level users on Multisite installations where it's otherwise expected that the user does not have permission to upload or execute arbitrary PHP code. Lower level users are not affected. Sites where the `DISALLOW_FILE_MODS` constant is set to `true` are not affected. Sites where an administrative user either does not need to enter FTP credentials or they have access to the valid FTP credentials, are not affected. The issue was fixed in WordPress 6.4.3 on January 30, 2024 and backported to versions 6.3.3, 6.2.4, 6.1.5, 6.0.7, 5.9.9, 5.8.9, 5.7.11, 5.6.13, 5.5.14, 5.4.15, 5.3.17, 5.2.20, 5.1.18, 5.0.21, 4.9.25, 2.8.24, 4.7.28, 4.6.28, 4.5.31, 4.4.32, 4.3.33, 4.2.37, and 4.1.40. A workaround is available. If the `DISALLOW_FILE_MODS` constant is defined as `true` then it will not be possible for any user to upload a plugin and therefore this issue will not be exploitable.

CVSS 7.7 · Hoch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • wordpress-develop

    Softwareversionen
    • >= 6.4.0, < 6.4.3: Betroffen
    • >= 6.3.0, < 6.3.3: Betroffen
    • >= 6.2.0, < 6.2.4: Betroffen
    • >= 6.1.0, < 6.1.5: Betroffen
    • >= 6.0.0, < 6.0.7: Betroffen
    • >= 5.9.0, < 5.9.9: Betroffen
    • >= 5.8.0, < 5.8.9: Betroffen
    • >= 5.7.0, < 5.7.11: Betroffen
    • >= 5.6.0, < 5.6.13: Betroffen
    • >= 5.5.0, < 5.5.14: Betroffen
    • >= 5.4.0, < 5.4.15: Betroffen
    • >= 5.3.0, < 5.3.17: Betroffen
    • >= 5.2.0, < 5.2.20: Betroffen
    • >= 5.1.0, < 5.1.18: Betroffen
    • >= 5.0.0, < 5.0.21: Betroffen
    • >= 4.9.0, < 4.9.25: Betroffen
    • >= 4.8.0, < 4.8.24: Betroffen
    • >= 4.7.0, < 4.7.28: Betroffen
    • >= 4.6.0, < 4.6.28: Betroffen
    • >= 4.5.0, < 4.5.31: Betroffen
    • >= 4.4.0, < 4.4.32: Betroffen
    • >= 4.3.0, < 4.3.33: Betroffen
    • >= 4.2.0, < 4.2.37: Betroffen
    • < 4.1.40: Betroffen

    Keine Korrektur veröffentlicht

  • wordpress Debian:12

    Softwareversionen
    • 6.1.1+dfsg1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.1.6+dfsg1-0+deb12u1

    Auf 6.1.6+dfsg1-0+deb12u1 aktualisieren

  • wordpress Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.4.3+dfsg1-1

    Auf 6.4.3+dfsg1-1 aktualisieren

  • wordpress Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.4.3+dfsg1-1

    Auf 6.4.3+dfsg1-1 aktualisieren

  • wordpress Ubuntu:16.04:LTS

    Softwareversionen
    • 4.3+dfsg-1
    • 4.3.1+dfsg-1
    • 4.4+dfsg-1
    • 4.4.1+dfsg-1
    • 4.4.2+dfsg-1
    • 4.4.2+dfsg-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:18.04:LTS

    Softwareversionen
    • 4.8.2+dfsg-2
    • 4.8.3+dfsg-1
    • 4.9.1+dfsg-1
    • 4.9.2+dfsg-1
    • 4.9.4+dfsg-1
    • 4.9.5+dfsg1-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:20.04:LTS

    Softwareversionen
    • 5.2.2+dfsg1-1
    • 5.2.4+dfsg1-1
    • 5.3.2+dfsg1-1
    • 5.3.2+dfsg1-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • wordpress Ubuntu:22.04:LTS

    Softwareversionen
    • 5.7.1+dfsg1-2ubuntu1
    • 5.8.1+dfsg1-2ubuntu1
    • 5.8.2+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1
    • 5.8.3+dfsg1-1ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →