CVE-2024-31210
CVE-2024-31210 · PHP file upload bypass via Plugin installer
This page contains facts from public vulnerability sources. Check the original advisory before updating.
WordPress is an open publishing platform for the Web. It's possible for a file of a type other than a zip file to be submitted as a new plugin by an administrative user on the Plugins -> Add New -> Upload Plugin screen in WordPress. If FTP credentials are requested for installation (in order to move the file into place outside of the `uploads` directory) then the uploaded file remains temporary available in the Media Library despite it not being allowed. If the `DISALLOW_FILE_EDIT` constant is set to `true` on the site _and_ FTP credentials are required when uploading a new theme or plugin, then this technically allows an RCE when the user would otherwise have no means of executing arbitrary PHP code. This issue _only_ affects Administrator level users on single site installations, and Super Admin level users on Multisite installations where it's otherwise expected that the user does not have permission to upload or execute arbitrary PHP code. Lower level users are not affected. Sites where the `DISALLOW_FILE_MODS` constant is set to `true` are not affected. Sites where an administrative user either does not need to enter FTP credentials or they have access to the valid FTP credentials, are not affected. The issue was fixed in WordPress 6.4.3 on January 30, 2024 and backported to versions 6.3.3, 6.2.4, 6.1.5, 6.0.7, 5.9.9, 5.8.9, 5.7.11, 5.6.13, 5.5.14, 5.4.15, 5.3.17, 5.2.20, 5.1.18, 5.0.21, 4.9.25, 2.8.24, 4.7.28, 4.6.28, 4.5.31, 4.4.32, 4.3.33, 4.2.37, and 4.1.40. A workaround is available. If the `DISALLOW_FILE_MODS` constant is defined as `true` then it will not be possible for any user to upload a plugin and therefore this issue will not be exploitable.
CVSS 7.7 · High · EPSS 1.0% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
wordpress-develop
- Versions
- >= 6.4.0, < 6.4.3: Affected
- >= 6.3.0, < 6.3.3: Affected
- >= 6.2.0, < 6.2.4: Affected
- >= 6.1.0, < 6.1.5: Affected
- >= 6.0.0, < 6.0.7: Affected
- >= 5.9.0, < 5.9.9: Affected
- >= 5.8.0, < 5.8.9: Affected
- >= 5.7.0, < 5.7.11: Affected
- >= 5.6.0, < 5.6.13: Affected
- >= 5.5.0, < 5.5.14: Affected
- >= 5.4.0, < 5.4.15: Affected
- >= 5.3.0, < 5.3.17: Affected
- >= 5.2.0, < 5.2.20: Affected
- >= 5.1.0, < 5.1.18: Affected
- >= 5.0.0, < 5.0.21: Affected
- >= 4.9.0, < 4.9.25: Affected
- >= 4.8.0, < 4.8.24: Affected
- >= 4.7.0, < 4.7.28: Affected
- >= 4.6.0, < 4.6.28: Affected
- >= 4.5.0, < 4.5.31: Affected
- >= 4.4.0, < 4.4.32: Affected
- >= 4.3.0, < 4.3.33: Affected
- >= 4.2.0, < 4.2.37: Affected
- < 4.1.40: Affected
No fix published
wordpress Debian:12
- Versions
- 6.1.1+dfsg1-1
- Affected ranges
- ECOSYSTEM: < 6.1.6+dfsg1-0+deb12u1
Update to 6.1.6+dfsg1-0+deb12u1
wordpress Debian:13
- Affected ranges
- ECOSYSTEM: < 6.4.3+dfsg1-1
Update to 6.4.3+dfsg1-1
wordpress Debian:14
- Affected ranges
- ECOSYSTEM: < 6.4.3+dfsg1-1
Update to 6.4.3+dfsg1-1
wordpress Ubuntu:16.04:LTS
- Versions
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:18.04:LTS
- Versions
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:20.04:LTS
- Versions
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
wordpress Ubuntu:22.04:LTS
- Versions
- 5.7.1+dfsg1-2ubuntu1
- 5.8.1+dfsg1-2ubuntu1
- 5.8.2+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1
- 5.8.3+dfsg1-1ubuntu1.1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published