p PatchFirst

CVE-2024-47606

CVE-2024-47606 · GHSL-2024-166: GStreamer Integer overflows in MP4/MOV demuxer and memory allocator that can lead to out-of-bounds writes

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GStreamer is a library for constructing graphs of media-handling components. An integer underflow has been detected in the function qtdemux_parse_theora_extension within qtdemux.c. The vulnerability occurs due to an underflow of the gint size variable, which causes size to hold a large unintended value when cast to an unsigned integer. This 32-bit negative value is then cast to a 64-bit unsigned integer (0xfffffffffffffffa) in a subsequent call to gst_buffer_new_and_alloc. The function gst_buffer_new_allocate then attempts to allocate memory, eventually calling _sysmem_new_block. The function _sysmem_new_block adds alignment and header size to the (unsigned) size, causing the overflow of the 'slice_size' variable. As a result, only 0x89 bytes are allocated, despite the large input size. When the following memcpy call occurs in gst_buffer_fill, the data from the input file will overwrite the content of the GstMapInfo info structure. Finally, during the call to gst_memory_unmap, the overwritten memory may cause a function pointer hijack, as the mem->allocator->mem_unmap_full function is called with a corrupted pointer. This function pointer overwrite could allow an attacker to alter the execution flow of the program, leading to arbitrary code execution. This vulnerability is fixed in 1.24.10.

CVSS 8.6 · Hoch · EPSS 1,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • gstreamer

    Softwareversionen
    • < 1.24.10: Betroffen

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Debian:12

    Softwareversionen
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.22.0-5+deb12u2

    Auf 1.22.0-5+deb12u2 aktualisieren

  • gst-plugins-good1.0 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gst-plugins-good1.0 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gstreamer1.0 Debian:12

    Softwareversionen
    • 1.22.0-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.22.0-2+deb12u1

    Auf 1.22.0-2+deb12u1 aktualisieren

  • gstreamer1.0 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gstreamer1.0 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gstreamer0.10 Ubuntu:14.04:LTS

    Softwareversionen
    • 0.10.36-1.2ubuntu1
    • 0.10.36-1.2ubuntu2
    • 0.10.36-1.2ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gstreamer1.0 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.2-1
    • 1.7.1-1
    • 1.7.2-1
    • 1.7.90-1
    • 1.7.91-1
    • 1.8.0-1
    • 1.8.1-1~ubuntu1
    • 1.8.2-1~ubuntu1
    • 1.8.3-1~ubuntu0.1
    • 1.8.3-1~ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good0.10 Ubuntu:16.04:LTS

    Softwareversionen
    • 0.10.31-3+nmu4ubuntu2~gcc5.1
    • 0.10.31-3+nmu4ubuntu2.16.04.1
    • 0.10.31-3+nmu4ubuntu2.16.04.2
    • 0.10.31-3+nmu4ubuntu2.16.04.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gstreamer0.10 Ubuntu:16.04:LTS

    Softwareversionen
    • 0.10.36-1.5ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    • 1.14.5-0ubuntu1~18.04.3+esm1
    • 1.14.5-0ubuntu1~18.04.3+esm2
    • 1.14.5-0ubuntu1~18.04.3+esm3
    • 1.14.5-0ubuntu1~18.04.3+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gstreamer1.0 Ubuntu:18.04:LTS

    Softwareversionen
    • 1.12.3-1
    • 1.12.4-1
    • 1.13.1-1
    • 1.13.91-1
    • 1.14.0-1
    • 1.14.1-1~ubuntu18.04.1
    • 1.14.1-1~ubuntu18.04.2
    • 1.14.4-1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Ubuntu:20.04:LTS

    Softwareversionen
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.16.3-0ubuntu1.3

    Auf 1.16.3-0ubuntu1.3 aktualisieren

  • gstreamer1.0 Ubuntu:20.04:LTS

    Softwareversionen
    • 1.16.1-1
    • 1.16.2-1
    • 1.16.2-2
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.16.3-0ubuntu1.2

    Auf 1.16.3-0ubuntu1.2 aktualisieren

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Softwareversionen
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.20.3-0ubuntu1.3

    Auf 1.20.3-0ubuntu1.3 aktualisieren

  • gstreamer1.0 Ubuntu:22.04:LTS

    Softwareversionen
    • 1.18.5-1
    • 1.19.90-1
    • 1.20.0-1
    • 1.20.1-1
    • 1.20.3-0ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.20.3-0ubuntu1.1

    Auf 1.20.3-0ubuntu1.1 aktualisieren

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Softwareversionen
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.2-1ubuntu1.1

    Auf 1.24.2-1ubuntu1.1 aktualisieren

  • gstreamer1.0 Ubuntu:24.04:LTS

    Softwareversionen
    • 1.22.5-1
    • 1.22.6-1
    • 1.22.7-1
    • 1.22.8-1
    • 1.22.10-1
    • 1.24.1-1
    • 1.24.1-1build1
    • 1.24.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.2-1ubuntu0.1

    Auf 1.24.2-1ubuntu0.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →