CVE-2024-47606
CVE-2024-47606 · GHSL-2024-166: GStreamer Integer overflows in MP4/MOV demuxer and memory allocator that can lead to out-of-bounds writes
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GStreamer is a library for constructing graphs of media-handling components. An integer underflow has been detected in the function qtdemux_parse_theora_extension within qtdemux.c. The vulnerability occurs due to an underflow of the gint size variable, which causes size to hold a large unintended value when cast to an unsigned integer. This 32-bit negative value is then cast to a 64-bit unsigned integer (0xfffffffffffffffa) in a subsequent call to gst_buffer_new_and_alloc. The function gst_buffer_new_allocate then attempts to allocate memory, eventually calling _sysmem_new_block. The function _sysmem_new_block adds alignment and header size to the (unsigned) size, causing the overflow of the 'slice_size' variable. As a result, only 0x89 bytes are allocated, despite the large input size. When the following memcpy call occurs in gst_buffer_fill, the data from the input file will overwrite the content of the GstMapInfo info structure. Finally, during the call to gst_memory_unmap, the overwritten memory may cause a function pointer hijack, as the mem->allocator->mem_unmap_full function is called with a corrupted pointer. This function pointer overwrite could allow an attacker to alter the execution flow of the program, leading to arbitrary code execution. This vulnerability is fixed in 1.24.10.
CVSS 8.6 · High · EPSS 1.7% · Fix available
- Published
- Updated
Stack: system
Affected products and versions
gstreamer
- Versions
- < 1.24.10: Affected
No fix published
gst-plugins-good1.0 Debian:12
- Versions
- 1.22.0-5
- 1.22.0-5+deb12u1
- Affected ranges
- ECOSYSTEM: < 1.22.0-5+deb12u2
Update to 1.22.0-5+deb12u2
gst-plugins-good1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gst-plugins-good1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gstreamer1.0 Debian:12
- Versions
- 1.22.0-2
- Affected ranges
- ECOSYSTEM: < 1.22.0-2+deb12u1
Update to 1.22.0-2+deb12u1
gstreamer1.0 Debian:13
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gstreamer1.0 Debian:14
- Affected ranges
- ECOSYSTEM: < 1.24.10-1
Update to 1.24.10-1
gstreamer0.10 Ubuntu:14.04:LTS
- Versions
- 0.10.36-1.2ubuntu1
- 0.10.36-1.2ubuntu2
- 0.10.36-1.2ubuntu3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1ubuntu1
- 1.6.1-1ubuntu1
- 1.6.2-1ubuntu1
- 1.7.1-1ubuntu1
- 1.7.2-1ubuntu1
- 1.7.90-1ubuntu1
- 1.7.91-1ubuntu1
- 1.8.0-1ubuntu1
- 1.8.1-1ubuntu0.1
- 1.8.2-1ubuntu0.1
- 1.8.2-1ubuntu0.2
- 1.8.2-1ubuntu0.3
- 1.8.3-1ubuntu0.3
- 1.8.3-1ubuntu0.4
- 1.8.3-1ubuntu0.5
- 1.8.3-1ubuntu0.5+esm1
- 1.8.3-1ubuntu0.5+esm2
- 1.8.3-1ubuntu0.5+esm3
- 1.8.3-1ubuntu0.5+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gstreamer1.0 Ubuntu:Pro:16.04:LTS
- Versions
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.7.1-1
- 1.7.2-1
- 1.7.90-1
- 1.7.91-1
- 1.8.0-1
- 1.8.1-1~ubuntu1
- 1.8.2-1~ubuntu1
- 1.8.3-1~ubuntu0.1
- 1.8.3-1~ubuntu0.1+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good0.10 Ubuntu:16.04:LTS
- Versions
- 0.10.31-3+nmu4ubuntu2~gcc5.1
- 0.10.31-3+nmu4ubuntu2.16.04.1
- 0.10.31-3+nmu4ubuntu2.16.04.2
- 0.10.31-3+nmu4ubuntu2.16.04.3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gstreamer0.10 Ubuntu:16.04:LTS
- Versions
- 0.10.36-1.5ubuntu1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS
- Versions
- 1.12.3-1ubuntu1
- 1.12.4-1ubuntu1
- 1.13.1-1ubuntu1
- 1.13.91-1ubuntu1
- 1.14.0-1ubuntu1
- 1.14.1-1ubuntu1~ubuntu18.04.1
- 1.14.4-1ubuntu1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- 1.14.5-0ubuntu1~18.04.3
- 1.14.5-0ubuntu1~18.04.3+esm1
- 1.14.5-0ubuntu1~18.04.3+esm2
- 1.14.5-0ubuntu1~18.04.3+esm3
- 1.14.5-0ubuntu1~18.04.3+esm4
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gstreamer1.0 Ubuntu:18.04:LTS
- Versions
- 1.12.3-1
- 1.12.4-1
- 1.13.1-1
- 1.13.91-1
- 1.14.0-1
- 1.14.1-1~ubuntu18.04.1
- 1.14.1-1~ubuntu18.04.2
- 1.14.4-1~ubuntu18.04.1
- 1.14.5-0ubuntu1~18.04.1
- 1.14.5-0ubuntu1~18.04.2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
gst-plugins-good1.0 Ubuntu:20.04:LTS
- Versions
- 1.16.1-1ubuntu1
- 1.16.2-1ubuntu1
- 1.16.2-1ubuntu2
- 1.16.2-1ubuntu2.1
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- 1.16.3-0ubuntu1.2
- Affected ranges
- ECOSYSTEM: < 1.16.3-0ubuntu1.3
Update to 1.16.3-0ubuntu1.3
gstreamer1.0 Ubuntu:20.04:LTS
- Versions
- 1.16.1-1
- 1.16.2-1
- 1.16.2-2
- 1.16.3-0ubuntu1
- 1.16.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.16.3-0ubuntu1.2
Update to 1.16.3-0ubuntu1.2
gst-plugins-good1.0 Ubuntu:22.04:LTS
- Versions
- 1.18.5-1ubuntu2
- 1.18.5-1ubuntu3
- 1.20.0-2ubuntu1
- 1.20.1-1ubuntu1
- 1.20.3-0ubuntu1
- 1.20.3-0ubuntu1.1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1.3
Update to 1.20.3-0ubuntu1.3
gstreamer1.0 Ubuntu:22.04:LTS
- Versions
- 1.18.5-1
- 1.19.90-1
- 1.20.0-1
- 1.20.1-1
- 1.20.3-0ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.20.3-0ubuntu1.1
Update to 1.20.3-0ubuntu1.1
gst-plugins-good1.0 Ubuntu:24.04:LTS
- Versions
- 1.22.6-1ubuntu1
- 1.22.6-1ubuntu2
- 1.22.8-3ubuntu1
- 1.22.9-1ubuntu1
- 1.24.0-1ubuntu5
- 1.24.0-1ubuntu7
- 1.24.1-2ubuntu1
- 1.24.2-1ubuntu1
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu1.1
Update to 1.24.2-1ubuntu1.1
gstreamer1.0 Ubuntu:24.04:LTS
- Versions
- 1.22.5-1
- 1.22.6-1
- 1.22.7-1
- 1.22.8-1
- 1.22.10-1
- 1.24.1-1
- 1.24.1-1build1
- 1.24.2-1
- Affected ranges
- ECOSYSTEM: < 1.24.2-1ubuntu0.1
Update to 1.24.2-1ubuntu0.1
Original sources
- https://securitylab.github.com/advisories/GHSL-2024-166_Gstreamer/
- https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/8032.patch
- https://gstreamer.freedesktop.org/security/sa-2024-0014.html
- https://lists.debian.org/debian-lts-announce/2024/12/msg00016.html
- https://security.netapp.com/advisory/ntap-20250418-0003/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00035.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-47606