CVE-2025-24794
CVE-2025-24794 · The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.
CVSS 6.7 · Mittel · EPSS 0,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
snowflake-connector-python
- Softwareversionen
- >= 2.7.12, < 3.13.1: Betroffen
Keine Korrektur veröffentlicht
snowflake-connector-python PyPI
- Softwareversionen
- 2.7.12
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.1.0
- 3.1.0a1
- 3.1.0a2
- 3.1.1
- 3.10.0
- 3.10.1
- 3.11.0
- 3.12.0
- 3.12.1
- 3.12.2
- 3.12.3
- 3.12.4
- 3.13.0
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.0b1
- 3.3.1
- 3.4.0
- 3.4.1
- 3.5.0
- 3.6.0
- 3.7.0
- 3.7.1
- 3.8.0
- 3.8.1
- 3.9.0
- 3.9.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.7.12, < 3.13.1
Auf 3.13.1 aktualisieren
snowflake-connector-python PyPI
- Softwareversionen
- 2.7.12
- 2.8.0
- 2.8.1
- 2.8.2
- 2.8.3
- 2.9.0
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.1.0
- 3.1.0a1
- 3.1.0a2
- 3.1.1
- 3.10.0
- 3.10.1
- 3.11.0
- 3.12.0
- 3.12.1
- 3.12.2
- 3.12.3
- 3.12.4
- 3.13.0
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.0b1
- 3.3.1
- 3.4.0
- 3.4.1
- 3.5.0
- 3.6.0
- 3.7.0
- 3.7.1
- 3.8.0
- 3.8.1
- 3.9.0
- 3.9.1
- Betroffene Versionsbereiche
- GIT: < 3769b43822357c3874c40f5e74068458c2dc79af
- ECOSYSTEM: ≥ 2.7.12, < 3.13.1
Auf 3.13.1 aktualisieren