p PatchFirst

CVE-2025-24794

CVE-2025-24794 · The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache

This page contains facts from public vulnerability sources. Check the original advisory before updating.

The Snowflake Connector for Python provides an interface for developing Python applications that can connect to Snowflake and perform all standard operations. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for Python. The OCSP response cache uses pickle as the serialization format, potentially leading to local privilege escalation. This vulnerability affects versions 2.7.12 through 3.13.0. Snowflake fixed the issue in version 3.13.1.

CVSS 6.7 · Medium · EPSS 0.3% · Fix available

Published
Updated

Stack: python

Affected products and versions

  • snowflake-connector-python

    Versions
    • >= 2.7.12, < 3.13.1: Affected

    No fix published

  • snowflake-connector-python PyPI

    Versions
    • 2.7.12
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.9.0
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.0a1
    • 3.1.0a2
    • 3.1.1
    • 3.10.0
    • 3.10.1
    • 3.11.0
    • 3.12.0
    • 3.12.1
    • 3.12.2
    • 3.12.3
    • 3.12.4
    • 3.13.0
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.3.0b1
    • 3.3.1
    • 3.4.0
    • 3.4.1
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.7.1
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    Affected ranges
    • ECOSYSTEM: ≥ 2.7.12, < 3.13.1

    Update to 3.13.1

  • snowflake-connector-python PyPI

    Versions
    • 2.7.12
    • 2.8.0
    • 2.8.1
    • 2.8.2
    • 2.8.3
    • 2.9.0
    • 3.0.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0.4
    • 3.1.0
    • 3.1.0a1
    • 3.1.0a2
    • 3.1.1
    • 3.10.0
    • 3.10.1
    • 3.11.0
    • 3.12.0
    • 3.12.1
    • 3.12.2
    • 3.12.3
    • 3.12.4
    • 3.13.0
    • 3.2.0
    • 3.2.1
    • 3.3.0
    • 3.3.0b1
    • 3.3.1
    • 3.4.0
    • 3.4.1
    • 3.5.0
    • 3.6.0
    • 3.7.0
    • 3.7.1
    • 3.8.0
    • 3.8.1
    • 3.9.0
    • 3.9.1
    Affected ranges
    • GIT: < 3769b43822357c3874c40f5e74068458c2dc79af
    • ECOSYSTEM: ≥ 2.7.12, < 3.13.1

    Update to 3.13.1

Original sources

Check your server →