p PatchFirst

CVE-2025-29783

CVE-2025-29783 · vLLM Allows Remote Code Execution via Mooncake Integration

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.

CVSS 9.1 · Kritisch · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • vllm

    Softwareversionen
    • >= 0.6.5, < 0.8.0: Betroffen

    Keine Korrektur veröffentlicht

  • vllm PyPI

    Softwareversionen
    • 0.6.5
    • 0.6.6
    • 0.6.6.post1
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.6.5, < 0.8.0

    Auf 0.8.0 aktualisieren

  • vllm PyPI

    Softwareversionen
    • 0.6.5
    • 0.6.6
    • 0.6.6.post1
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    Betroffene Versionsbereiche
    • GIT: < 288ca110f68d23909728627d3100e5a8db820aa2
    • ECOSYSTEM: ≥ 0.6.5, < 0.8.0

    Auf 0.8.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →