CVE-2025-29783
CVE-2025-29783 · vLLM Allows Remote Code Execution via Mooncake Integration
This page contains facts from public vulnerability sources. Check the original advisory before updating.
vLLM is a high-throughput and memory-efficient inference and serving engine for LLMs. When vLLM is configured to use Mooncake, unsafe deserialization exposed directly over ZMQ/TCP on all network interfaces will allow attackers to execute remote code on distributed hosts. This is a remote code execution vulnerability impacting any deployments using Mooncake to distribute KV across distributed hosts. This vulnerability is fixed in 0.8.0.
CVSS 9.1 · Critical · EPSS 0.7% · Fix available
- Published
- Updated
Stack: python
Affected products and versions
vllm
- Versions
- >= 0.6.5, < 0.8.0: Affected
No fix published
vllm PyPI
- Versions
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- Affected ranges
- ECOSYSTEM: ≥ 0.6.5, < 0.8.0
Update to 0.8.0
vllm PyPI
- Versions
- 0.6.5
- 0.6.6
- 0.6.6.post1
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- Affected ranges
- GIT: < 288ca110f68d23909728627d3100e5a8db820aa2
- ECOSYSTEM: ≥ 0.6.5, < 0.8.0
Update to 0.8.0