CVE-2025-46817
CVE-2025-46817 · Lua library commands may lead to integer overflow and potential RCE
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.
CVSS 7.0 · Hoch · EPSS 3,9% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · database
Betroffene Produkte und Versionen
redis
- Softwareversionen
- < 8.2.2: Betroffen
Keine Korrektur veröffentlicht
redict Debian:14
- Softwareversionen
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1
- 7.3.2+ds-1~bpo12+1
- 7.3.5+ds-1
- 7.3.5+ds-1~bpo12+1
- 7.3.6+ds-1~bpo12+1
- 7.3.6+ds-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.3.6+ds-1
Auf 7.3.6+ds-1 aktualisieren
redis Debian:12
- Softwareversionen
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- 5:7.0.15-1~deb12u3
- 5:7.0.15-1~deb12u4
- 5:7.0.15-1~deb12u5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:7.0.15-1~deb12u6
Auf 5:7.0.15-1~deb12u6 aktualisieren
redis Debian:13
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.2-3+deb13u1
Auf 5:8.0.2-3+deb13u1 aktualisieren
redis Debian:14
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.4-1
Auf 5:8.0.4-1 aktualisieren
valkey Debian:13
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.1+dfsg1-3+deb13u1
Auf 8.1.1+dfsg1-3+deb13u1 aktualisieren
valkey Debian:14
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.4+dfsg1-1
Auf 8.1.4+dfsg1-1 aktualisieren
valkey Ubuntu:24.04:LTS
- Softwareversionen
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.2
- 7.2.8+dfsg1-0ubuntu0.24.04.3
- 7.2.10+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.2.11+dfsg1-0ubuntu0.2
Auf 7.2.11+dfsg1-0ubuntu0.2 aktualisieren
redict Ubuntu:25.10
- Softwareversionen
- 7.3.2+ds-1
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.5+ds-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
valkey Ubuntu:25.10
- Softwareversionen
- 8.0.2+dfsg1-1ubuntu1
- 8.1.1+dfsg1-2ubuntu1
- 8.1.3+dfsg1-0ubuntu1
- 8.1.3+dfsg1-0ubuntu2
- 8.1.4+dfsg1-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.4+dfsg1-0ubuntu0.2
Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
redict Ubuntu:26.10
- Softwareversionen
- 7.3.6+ds-1
- 7.3.6+ds-2
- 7.3.6+ds-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redict Ubuntu:26.04:LTS
- Softwareversionen
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.6+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht