p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in valkey

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für valkey: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 7

  1. CVE-2026-21863

    Hoch · CVSS 7.5EPSS 0,85%Korrektur verfügbar

    Malformed Valkey Cluster bus message can lead to Remote DoS

    Valkey is a distributed key-value database. Prior to versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12, a malicious actor with access to the Valkey clusterbus port can send an invalid packet that may cause an out bound read, which might result in the system crashing. The Valkey clusterbus packet processing code does not validate that a clusterbus ping extension packet is located within buffer of the clusterbus packet before attempting to read it. Versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12 fix the issue. As an additional mitigation, don't expose the cluster bus connection directly to end users, and protect the connection with its own network ACLs.

    • Auf 8.1.6+dfsg1-0ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  2. CVE-2025-67733

    Hoch · CVSS 8.5EPSS 0,65%Korrektur verfügbar

    Valkey Affected by RESP Protocol Injection via Lua error_reply

    Valkey is a distributed key-value database. Prior to versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12, a malicious user can use scripting commands to inject arbitrary information into the response stream for the given client, potentially corrupting or returning tampered data to other users on the same connection. The error handling code for lua scripts does not properly handle null characters. Versions 9.0.2, 8.1.6, 8.0.7, and 7.2.12 fix the issue.

    • Auf 8.1.6+dfsg1-0ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  3. CVE-2025-49844

    Kritisch · CVSS 10EPSS 82,64%Öffentlicher ExploitKorrektur verfügbar

    Redis Lua Use-After-Free may lead to remote code execution

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate the garbage collector, trigger a use-after-free and potentially lead to remote code execution. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to restrict EVAL and EVALSHA commands.

    • Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  4. CVE-2025-46819

    Mittel · CVSS 6.3EPSS 1,09%Öffentlicher ExploitKorrektur verfügbar

    Redis is vulnerable to DoS via specially crafted LUA scripts

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

    • Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  5. CVE-2025-46818

    Mittel · CVSS 6EPSS 0,74%Öffentlicher ExploitKorrektur verfügbar

    Redis: Authenticated users can execute LUA scripts as a different user

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to manipulate different LUA objects and potentially run their own code in the context of another user. The problem exists in all versions of Redis with LUA scripting. This issue is fixed in version 8.2.2. A workaround to mitigate the problem without patching the redis-server executable is to prevent users from executing LUA scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.

    • Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2025-46817

    Hoch · CVSS 7EPSS 3,92%Öffentlicher ExploitKorrektur verfügbar

    Lua library commands may lead to integer overflow and potential RCE

    Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted Lua script to cause an integer overflow and potentially lead to remote code execution The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2.

    • Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →