CVE-2025-46819
CVE-2025-46819 · Redis is vulnerable to DoS via specially crafted LUA scripts
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Redis is an open source, in-memory database that persists on disk. Versions 8.2.1 and below allow an authenticated user to use a specially crafted LUA script to read out-of-bound data or crash the server and subsequent denial of service. The problem exists in all versions of Redis with Lua scripting. This issue is fixed in version 8.2.2. To workaround this issue without patching the redis-server executable is to prevent users from executing Lua scripts. This can be done using ACL to block a script by restricting both the EVAL and FUNCTION command families.
CVSS 6.3 · Mittel · EPSS 1,1% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · database
Betroffene Produkte und Versionen
redis
- Softwareversionen
- < 8.2.2: Betroffen
Keine Korrektur veröffentlicht
redict Debian:14
- Softwareversionen
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1
- 7.3.2+ds-1~bpo12+1
- 7.3.5+ds-1
- 7.3.5+ds-1~bpo12+1
- 7.3.6+ds-1~bpo12+1
- 7.3.6+ds-1~bpo13+1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.3.6+ds-1
Auf 7.3.6+ds-1 aktualisieren
redis Debian:12
- Softwareversionen
- 5:7.0.11-1
- 5:7.0.11-1+deb12u1
- 5:7.0.12-1
- 5:7.0.12-2
- 5:7.0.13-1
- 5:7.0.13-2
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1~deb12u1
- 5:7.0.15-1~deb12u2
- 5:7.0.15-1~deb12u3
- 5:7.0.15-1~deb12u4
- 5:7.0.15-1~deb12u5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:7.0.15-1~deb12u6
Auf 5:7.0.15-1~deb12u6 aktualisieren
redis Debian:13
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.2-3+deb13u1
Auf 5:8.0.2-3+deb13u1 aktualisieren
redis Debian:14
- Softwareversionen
- 5:8.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5:8.0.4-1
Auf 5:8.0.4-1 aktualisieren
valkey Debian:13
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.1+dfsg1-3+deb13u1
Auf 8.1.1+dfsg1-3+deb13u1 aktualisieren
valkey Debian:14
- Softwareversionen
- 8.1.1+dfsg1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.4+dfsg1-1
Auf 8.1.4+dfsg1-1 aktualisieren
redis Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2:2.6.13-1
- 2:2.6.16-3
- 2:2.8.0-1
- 2:2.8.2-1
- 2:2.8.4-2
- 2:2.8.4-2ubuntu0.2
- 2:2.8.4-2ubuntu0.2+esm1
- 2:2.8.4-2ubuntu0.2+esm2
- 2:2.8.4-2ubuntu0.2+esm3
- 2:2.8.4-2ubuntu0.2+esm4
- 2:2.8.4-2ubuntu0.2+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2:3.0.3-3
- 2:3.0.5-1
- 2:3.0.5-2
- 2:3.0.5-3
- 2:3.0.5-4
- 2:3.0.6-1
- 2:3.0.6-1ubuntu0.2
- 2:3.0.6-1ubuntu0.3
- 2:3.0.6-1ubuntu0.4
- 2:3.0.6-1ubuntu0.4+esm1
- 2:3.0.6-1ubuntu0.4+esm2
- 2:3.0.6-1ubuntu0.4+esm3
- 2:3.0.6-1ubuntu0.4+esm4
- 2:3.0.6-1ubuntu0.4+esm5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4:4.0.1-7
- 4:4.0.2-6
- 4:4.0.2-9
- 5:4.0.5-1
- 5:4.0.6-1
- 5:4.0.6-2
- 5:4.0.7-1
- 5:4.0.8-1
- 5:4.0.8-2
- 5:4.0.9-1
- 5:4.0.9-1ubuntu0.1
- 5:4.0.9-1ubuntu0.2
- 5:4.0.9-1ubuntu0.2+esm2
- 5:4.0.9-1ubuntu0.2+esm3
- 5:4.0.9-1ubuntu0.2+esm4
- 5:4.0.9-1ubuntu0.2+esm5
- 5:4.0.9-1ubuntu0.2+esm6
- 5:4.0.9-1ubuntu0.2+esm7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5:5.0.5-2build1
- 5:5.0.6-1
- 5:5.0.7-1
- 5:5.0.7-2
- 5:5.0.7-2ubuntu0.1~esm1
- 5:5.0.7-2ubuntu0.1
- 5:5.0.7-2ubuntu0.1+esm1
- 5:5.0.7-2ubuntu0.1+esm2
- 5:5.0.7-2ubuntu0.1+esm3
- 5:5.0.7-2ubuntu0.1+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 5:6.0.15-1
- 5:6.0.16-1
- 5:6.0.16-1build1
- 5:6.0.16-1ubuntu1
- 5:6.0.16-1ubuntu1+esm1
- 5:6.0.16-1ubuntu1+esm2
- 5:6.0.16-1ubuntu1.1
- 5:6.0.16-1ubuntu1.1+esm1
- 5:6.0.16-1ubuntu1.2
- 5:6.0.16-1ubuntu1.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:24.04:LTS
- Softwareversionen
- 5:7.0.12-1
- 5:7.0.14-1
- 5:7.0.14-2
- 5:7.0.15-1
- 5:7.0.15-1build1
- 5:7.0.15-1build2
- 5:7.0.15-1ubuntu0.24.04.1
- 5:7.0.15-1ubuntu0.24.04.2
- 5:7.0.15-1ubuntu0.24.04.3
- 5:7.0.15-1ubuntu0.24.04.4
- 5:7.0.15-1ubuntu0.24.04.5
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
valkey Ubuntu:24.04:LTS
- Softwareversionen
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.2
- 7.2.8+dfsg1-0ubuntu0.24.04.3
- 7.2.10+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 7.2.11+dfsg1-0ubuntu0.2
Auf 7.2.11+dfsg1-0ubuntu0.2 aktualisieren
redict Ubuntu:25.10
- Softwareversionen
- 7.3.2+ds-1
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.5+ds-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:25.10
- Softwareversionen
- 5:7.0.15-3
- 5:7.0.15-3.1
- 5:8.0.2-3
- 5:8.0.2-3build1
- 5:8.0.2-3ubuntu0.25.10.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
valkey Ubuntu:25.10
- Softwareversionen
- 8.0.2+dfsg1-1ubuntu1
- 8.1.1+dfsg1-2ubuntu1
- 8.1.3+dfsg1-0ubuntu1
- 8.1.3+dfsg1-0ubuntu2
- 8.1.4+dfsg1-0ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.4+dfsg1-0ubuntu0.2
Auf 8.1.4+dfsg1-0ubuntu0.2 aktualisieren
redict Ubuntu:26.10
- Softwareversionen
- 7.3.6+ds-1
- 7.3.6+ds-2
- 7.3.6+ds-2build1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:26.10
- Softwareversionen
- 5:8.0.5-1
- 5:8.0.6-2
- 5:8.0.6-2build1
- 5:8.0.6-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redict Ubuntu:26.04:LTS
- Softwareversionen
- 7.3.5+ds-1
- 7.3.5+ds-1ubuntu0.1
- 7.3.6+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
redis Ubuntu:26.04:LTS
- Softwareversionen
- 5:8.0.2-3build1
- 5:8.0.2-3ubuntu0.25.10.1
- 5:8.0.5-1
- 5:8.0.5-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/redis/redis/security/advisories/GHSA-4c68-q8q8-3g4f
- https://github.com/redis/redis/commit/3a1624da2449ac3dbfc4bdaed43adf77a0b7bfba
- https://github.com/redis/redis/releases/tag/8.2.2
- https://www.vicarius.io/vsociety/posts/cve-2025-46819-detect-redis-vulnerability
- https://www.vicarius.io/vsociety/posts/cve-2025-46819-mitigate-redis-vulnerability
- https://nvd.nist.gov/vuln/detail/CVE-2025-46819