p PatchFirst

CVE-2025-54585

CVE-2025-54585 · GitProxy is vulnerable to a new branch approval exploit

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GitProxy is an application that stands between developers and a Git remote endpoint. In versions 1.19.1 and below, attackers can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. The vulnerability impacts all users or organizations relying on GitProxy to enforce policy and prevent unapproved changes. It requires no elevated privileges beyond regular push access, and no extra user interaction. It does however, require a GitProxy administrator or designated user (canUserApproveRejectPush) to approve pushes to the child branch. This is fixed in version 1.19.2.

CVSS 8.2 · Hoch · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • git-proxy

    Softwareversionen
    • < 1.19.2: Betroffen

    Keine Korrektur veröffentlicht

  • @finos/git-proxy npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.19.2

    Auf 1.19.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →