CVE-2025-54585
CVE-2025-54585 · GitProxy is vulnerable to a new branch approval exploit
This page contains facts from public vulnerability sources. Check the original advisory before updating.
GitProxy is an application that stands between developers and a Git remote endpoint. In versions 1.19.1 and below, attackers can exploit the way GitProxy handles new branch creation to bypass the approval of prior commits on the parent branch. The vulnerability impacts all users or organizations relying on GitProxy to enforce policy and prevent unapproved changes. It requires no elevated privileges beyond regular push access, and no extra user interaction. It does however, require a GitProxy administrator or designated user (canUserApproveRejectPush) to approve pushes to the child branch. This is fixed in version 1.19.2.
CVSS 8.2 · High · EPSS 0.4% · Fix available
- Published
- Updated
Stack: node
Affected products and versions
git-proxy
- Versions
- < 1.19.2: Affected
No fix published
@finos/git-proxy npm
- Affected ranges
- SEMVER: < 1.19.2
Update to 1.19.2
Original sources
- https://github.com/finos/git-proxy/security/advisories/GHSA-39p2-8hq9-fwj6
- https://github.com/finos/git-proxy/commit/a620a2f33c39c78e01783a274580bf822af3cc3a
- https://github.com/finos/git-proxy/commit/f99fe42082eab0970e4cd0acdc3421a527a7e531
- https://github.com/finos/git-proxy/releases/tag/v1.19.2
- https://nvd.nist.gov/vuln/detail/CVE-2025-54585