p PatchFirst

CVE-2025-58056

CVE-2025-58056 · Netty is vulnerable to request smuggling due to incorrect parsing of chunk extensions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Netty is an asynchronous event-driven network application framework for development of maintainable high performance protocol servers and clients. In versions 4.1.124.Final, and 4.2.0.Alpha3 through 4.2.4.Final, Netty incorrectly accepts standalone newline characters (LF) as a chunk-size line terminator, regardless of a preceding carriage return (CR), instead of requiring CRLF per HTTP/1.1 standards. When combined with reverse proxies that parse LF differently (treating it as part of the chunk extension), attackers can craft requests that the proxy sees as one request but Netty processes as two, enabling request smuggling attacks. This is fixed in versions 4.1.125.Final and 4.2.5.Final.

CVSS 2.9 · Niedrig · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • netty

    Softwareversionen
    • >= 4.2.0.Alpha3, < 4.2.5.Final: Betroffen
    • <= 4.1.124.Final, < 4.1.125.Final: Betroffen

    Keine Korrektur veröffentlicht

  • netty Debian:12

    Softwareversionen
    • 1:4.1.48-7
    • 1:4.1.48-7+deb12u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-7+deb12u2

    Auf 1:4.1.48-7+deb12u2 aktualisieren

  • netty Debian:13

    Softwareversionen
    • 1:4.1.48-10
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-10+deb13u1

    Auf 1:4.1.48-10+deb13u1 aktualisieren

  • netty Debian:14

    Softwareversionen
    • 1:4.1.48-10
    • 1:4.1.48-11
    • 1:4.1.48-12
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-13

    Auf 1:4.1.48-13 aktualisieren

  • netty Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    • 1:4.0.34-1ubuntu0.1~esm1
    • 1:4.0.34-1ubuntu0.1~esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm3

    Auf 1:4.0.34-1ubuntu0.1~esm3 aktualisieren

  • netty-3.9 Ubuntu:16.04:LTS

    Softwareversionen
    • 3.9.0.Final-1
    • 3.9.0.Final-1ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    • 1:4.1.7-4ubuntu0.1+esm2
    • 1:4.1.7-4ubuntu0.1+esm3
    • 1:4.1.7-4ubuntu0.1+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm5

    Auf 1:4.1.7-4ubuntu0.1+esm5 aktualisieren

  • netty-3.9 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.9.9.Final-1
    • 3.9.9.Final-1+deb9u1build0.18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    • 1:4.1.45-1ubuntu0.1~esm1
    • 1:4.1.45-1ubuntu0.1~esm2
    • 1:4.1.45-1ubuntu0.1~esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm4

    Auf 1:4.1.45-1ubuntu0.1~esm4 aktualisieren

  • netty Ubuntu:22.04:LTS

    Softwareversionen
    • 1:4.1.48-4
    • 1:4.1.48-4+deb11u1build0.22.04.1
    • 1:4.1.48-4+deb11u2build0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1

    Auf 1:4.1.48-4+deb11u2ubuntu0.1 aktualisieren

  • netty Ubuntu:24.04:LTS

    Softwareversionen
    • 1:4.1.48-7
    • 1:4.1.48-8
    • 1:4.1.48-9
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-9ubuntu0.1

    Auf 1:4.1.48-9ubuntu0.1 aktualisieren

  • netty Ubuntu:25.10

    Softwareversionen
    • 1:4.1.48-10
    • 1:4.1.48-10ubuntu0.25.10.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-10ubuntu0.25.10.2

    Auf 1:4.1.48-10ubuntu0.25.10.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →