p PatchFirst

PatchFirst · Aktuelle Sicherheitslücken

Sicherheitslücken in netty-3.9

In den letzten 30 Tagen veröffentlichte Sicherheitslücken für netty-3.9: 0. Davon im KEV-Katalog: 0.

Sicherheitslücken filtern
Filter zurücksetzen

Sicherheitslücken: 9

  1. CVE-2025-58056

    Niedrig · CVSS 2.9EPSS 0,71%Keine Korrektur veröffentlicht

    Netty is vulnerable to request smuggling due to incorrect parsing of chunk extensions

    Netty is an asynchronous event-driven network application framework for development of maintainable high performance protocol servers and clients. In versions 4.1.124.Final, and 4.2.0.Alpha3 through 4.2.4.Final, Netty incorrectly accepts standalone newline characters (LF) as a chunk-size line terminator, regardless of a preceding carriage return (CR), instead of requiring CRLF per HTTP/1.1 standards. When combined with reverse proxies that parse LF differently (treating it as part of the chunk extension), attackers can craft requests that the proxy sees as one request but Netty processes as two, enabling request smuggling attacks. This is fix

    Veröffentlicht Aktualisiert
  2. CVE-2024-47535

    Mittel · CVSS 5.5EPSS 0,41%Keine Korrektur veröffentlicht

    Denial of Service attack on windows app using Netty

    Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. An unsafe reading of environment file could potentially cause a denial of service in Netty. When loaded on an Windows application, Netty attempts to load a file that does not exist. If an attacker creates such a large file, the Netty application crashes. This vulnerability is fixed in 4.1.115.

    Veröffentlicht Aktualisiert
  3. CVE-2022-41915

    Mittel · CVSS 6.5EPSS 0,95%Keine Korrektur veröffentlicht

    CVE-2022-41915

    Netty project is an event-driven asynchronous network application framework. Starting in version 4.1.83.Final and prior to 4.1.86.Final, when calling `DefaultHttpHeadesr.set` with an _iterator_ of values, header value validation was not performed, allowing malicious header values in the iterator to perform HTTP Response Splitting. This issue has been patched in version 4.1.86.Final. Integrators can work around the issue by changing the `DefaultHttpHeaders.set(CharSequence, Iterator<?>)` call, into a `remove()` call, and call `add()` in a loop over the iterator of values.

    Veröffentlicht Aktualisiert
  4. CVE-2022-41881

    Mittel · CVSS 5.3EPSS 1,58%Keine Korrektur veröffentlicht

    CVE-2022-41881

    Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.

    Veröffentlicht Aktualisiert
  5. CVE-2020-7238

    Hoch · CVSS 7.5EPSS 3,65%Korrektur verfügbar

    CVE-2020-7238

    Netty 4.1.43.Final allows HTTP Request Smuggling because it mishandles Transfer-Encoding whitespace (such as a [space]Transfer-Encoding:chunked line) and a later Content-Length header. This issue exists because of an incomplete fix for CVE-2019-16869.

    • Auf 3.9.0.Final-1ubuntu0.1 aktualisieren
    Veröffentlicht Aktualisiert
  6. CVE-2015-2156

    Hoch · CVSS 7.5EPSS 5,22%Keine Korrektur veröffentlicht

    CVE-2015-2156

    Netty before 3.9.8.Final, 3.10.x before 3.10.3.Final, 4.0.x before 4.0.28.Final, and 4.1.x before 4.1.0.Beta5 and Play Framework 2.x before 2.3.9 might allow remote attackers to bypass the httpOnly flag on cookies and obtain sensitive information by leveraging improper validation of cookie name and value characters.

    Veröffentlicht Aktualisiert

Prüfen Sie Ihren Server

Gleichen Sie Ihren installierten Stack und seine Versionen mit den aktuellen Sicherheitsmeldungen ab.

Prüfen Sie Ihren Server →