CVE-2025-66293
CVE-2025-66293 · LIBPNG has an out-of-bounds read in png_image_read_composite
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.52, an out-of-bounds read vulnerability in libpng's simplified API allows reading up to 1012 bytes beyond the png_sRGB_base[512] array when processing valid palette PNG images with partial transparency and gamma correction. The PNG files that trigger this vulnerability are valid per the PNG specification; the bug is in libpng's internal state management. Upgrade to libpng 1.6.52 or later.
CVSS 7.1 · Hoch · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libpng
- Softwareversionen
- < 1.6.52: Betroffen
Keine Korrektur veröffentlicht
libpng1.6 Debian:12
- Softwareversionen
- 1.6.39-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.39-2+deb12u1
Auf 1.6.39-2+deb12u1 aktualisieren
libpng1.6 Debian:13
- Softwareversionen
- 1.6.48-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.48-1+deb13u1
Auf 1.6.48-1+deb13u1 aktualisieren
libpng1.6 Debian:14
- Softwareversionen
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1
- 1.6.50-1~exp1
- 1.6.51-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.52-1
Auf 1.6.52-1 aktualisieren
libpng1.6 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1.6.20-2
- 1.6.20-2ubuntu0.1~esm1
- 1.6.20-2ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3
Auf 1.6.20-2ubuntu0.1~esm3 aktualisieren
libpng1.6 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1.6.34-1
- 1.6.34-1ubuntu0.18.04.1
- 1.6.34-1ubuntu0.18.04.2
- 1.6.34-1ubuntu0.18.04.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2
Auf 1.6.34-1ubuntu0.18.04.2+esm2 aktualisieren
libpng1.6 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1.6.37-1
- 1.6.37-2
- 1.6.37-2ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2
Auf 1.6.37-2ubuntu0.1~esm2 aktualisieren
libpng1.6 Ubuntu:22.04:LTS
- Softwareversionen
- 1.6.37-3build4
- 1.6.37-3build5
- 1.6.37-3ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.37-3ubuntu0.3
Auf 1.6.37-3ubuntu0.3 aktualisieren
libpng1.6 Ubuntu:24.04:LTS
- Softwareversionen
- 1.6.40-1
- 1.6.40-2
- 1.6.40-3
- 1.6.42-1
- 1.6.43-1
- 1.6.43-3
- 1.6.43-5build1
- 1.6.43-5ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.43-5ubuntu0.3
Auf 1.6.43-5ubuntu0.3 aktualisieren
libpng1.6 Ubuntu:25.10
- Softwareversionen
- 1.6.47-1.1
- 1.6.48-1
- 1.6.49-1~exp1
- 1.6.50-1~exp1
- 1.6.50-1
- 1.6.50-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.6.50-1ubuntu0.3
Auf 1.6.50-1ubuntu0.3 aktualisieren
Originalquellen
- https://github.com/pnggroup/libpng/security/advisories/GHSA-9mpm-9pxh-mg4f
- https://github.com/pnggroup/libpng/issues/764
- https://github.com/pnggroup/libpng/commit/788a624d7387a758ffd5c7ab010f1870dea753a1
- https://github.com/pnggroup/libpng/commit/a05a48b756de63e3234ea6b3b938b8f5f862484a
- http://www.openwall.com/lists/oss-security/2025/12/03/6
- http://www.openwall.com/lists/oss-security/2025/12/03/7
- http://www.openwall.com/lists/oss-security/2025/12/03/8
- https://nvd.nist.gov/vuln/detail/CVE-2025-66293