p PatchFirst

CVE-2025-66293

CVE-2025-66293 · LIBPNG has an out-of-bounds read in png_image_read_composite

This page contains facts from public vulnerability sources. Check the original advisory before updating.

LIBPNG is a reference library for use in applications that read, create, and manipulate PNG (Portable Network Graphics) raster image files. Prior to 1.6.52, an out-of-bounds read vulnerability in libpng's simplified API allows reading up to 1012 bytes beyond the png_sRGB_base[512] array when processing valid palette PNG images with partial transparency and gamma correction. The PNG files that trigger this vulnerability are valid per the PNG specification; the bug is in libpng's internal state management. Upgrade to libpng 1.6.52 or later.

CVSS 7.1 · High · EPSS 0.4% · Fix available

Published
Updated

Stack: system

Affected products and versions

  • libpng

    Versions
    • < 1.6.52: Affected

    No fix published

  • libpng1.6 Debian:12

    Versions
    • 1.6.39-2
    Affected ranges
    • ECOSYSTEM: < 1.6.39-2+deb12u1

    Update to 1.6.39-2+deb12u1

  • libpng1.6 Debian:13

    Versions
    • 1.6.48-1
    Affected ranges
    • ECOSYSTEM: < 1.6.48-1+deb13u1

    Update to 1.6.48-1+deb13u1

  • libpng1.6 Debian:14

    Versions
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1
    • 1.6.50-1~exp1
    • 1.6.51-1
    Affected ranges
    • ECOSYSTEM: < 1.6.52-1

    Update to 1.6.52-1

  • libpng1.6 Ubuntu:Pro:16.04:LTS

    Versions
    • 1.6.20-2
    • 1.6.20-2ubuntu0.1~esm1
    • 1.6.20-2ubuntu0.1~esm2
    Affected ranges
    • ECOSYSTEM: < 1.6.20-2ubuntu0.1~esm3

    Update to 1.6.20-2ubuntu0.1~esm3

  • libpng1.6 Ubuntu:Pro:18.04:LTS

    Versions
    • 1.6.34-1
    • 1.6.34-1ubuntu0.18.04.1
    • 1.6.34-1ubuntu0.18.04.2
    • 1.6.34-1ubuntu0.18.04.2+esm1
    Affected ranges
    • ECOSYSTEM: < 1.6.34-1ubuntu0.18.04.2+esm2

    Update to 1.6.34-1ubuntu0.18.04.2+esm2

  • libpng1.6 Ubuntu:Pro:20.04:LTS

    Versions
    • 1.6.37-1
    • 1.6.37-2
    • 1.6.37-2ubuntu0.1~esm1
    Affected ranges
    • ECOSYSTEM: < 1.6.37-2ubuntu0.1~esm2

    Update to 1.6.37-2ubuntu0.1~esm2

  • libpng1.6 Ubuntu:22.04:LTS

    Versions
    • 1.6.37-3build4
    • 1.6.37-3build5
    • 1.6.37-3ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.37-3ubuntu0.3

    Update to 1.6.37-3ubuntu0.3

  • libpng1.6 Ubuntu:24.04:LTS

    Versions
    • 1.6.40-1
    • 1.6.40-2
    • 1.6.40-3
    • 1.6.42-1
    • 1.6.43-1
    • 1.6.43-3
    • 1.6.43-5build1
    • 1.6.43-5ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.43-5ubuntu0.3

    Update to 1.6.43-5ubuntu0.3

  • libpng1.6 Ubuntu:25.10

    Versions
    • 1.6.47-1.1
    • 1.6.48-1
    • 1.6.49-1~exp1
    • 1.6.50-1~exp1
    • 1.6.50-1
    • 1.6.50-1ubuntu0.1
    Affected ranges
    • ECOSYSTEM: < 1.6.50-1ubuntu0.3

    Update to 1.6.50-1ubuntu0.3

Original sources

Check your server →