CVE-2026-102831
CVE-2026-102831 · JupyterLab: Cross-site scripting (XSS) in JupyterLab via notebook cells pasted from the system clipboard
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From JupyterLab 4.5.0 until 4.5.11 and 4.6.4, from Notebook 7.5.0 until 7.6.3, and from JupyterLite Core 0.7.0 until 0.8.4, the system clipboard cell-paste path accepts attacker-controlled cell JSON without clearing metadata.trusted. When useSystemClipboardForCells is active and pasteCodeCellsWithoutOutput is disabled, a pasted code cell can mark HTML output as trusted, bypass output sanitization, and execute script in the authenticated JupyterLab origin without executing the cell. Markdown and raw cells are not affected because their output is sanitized. This issue is fixed in JupyterLab 4.5.11 and 4.6.4, Notebook 7.6.3, and JupyterLite Core 0.8.4.
CVSS 8.1 · Hoch · EPSS 0,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
jupyterlab
- Softwareversionen
- >= 4.5.0, < 4.5.11: Betroffen
- >= 4.6.0, < 4.6.4: Betroffen
Keine Korrektur veröffentlicht
notebook
- Softwareversionen
- >= 7.5.0, < 7.6.3: Betroffen
Keine Korrektur veröffentlicht
jupyterlite-core
- Softwareversionen
- >= 0.7.0, < 0.8.4: Betroffen
Keine Korrektur veröffentlicht
jupyter-notebook Debian:12
- Softwareversionen
- 6.4.12-2.2
- 6.4.13-1
- 6.4.13-2
- 6.4.13-3
- 6.4.13-4
- 6.4.13-5
- 7.0.0-1
- 7.0.0-2
- 7.4.7-1
- 7.4.7-2
- 7.4.7-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Debian:13
- Softwareversionen
- 6.4.13-5
- 7.0.0-1
- 7.0.0-2
- 7.4.7-1
- 7.4.7-2
- 7.4.7-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Debian:14
- Softwareversionen
- 6.4.13-5
- 7.0.0-1
- 7.0.0-2
- 7.4.7-1
- 7.4.7-2
- 7.4.7-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab PyPI
- Softwareversionen
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.6.0, < 4.6.4
Auf 4.6.4 aktualisieren
jupyterlab PyPI
- Softwareversionen
- 4.5.0
- 4.5.1
- 4.5.10
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.5.0, < 4.5.11
Auf 4.5.11 aktualisieren
notebook PyPI
- Softwareversionen
- 7.5.0
- 7.5.1
- 7.5.2
- 7.5.3
- 7.5.4
- 7.5.5
- 7.5.6
- 7.5.7
- 7.6.0
- 7.6.0a0
- 7.6.0a1
- 7.6.0a2
- 7.6.0a3
- 7.6.0a4
- 7.6.0a5
- 7.6.0b0
- 7.6.0b1
- 7.6.0rc0
- 7.6.0rc1
- 7.6.1
- 7.6.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 7.5.0, < 7.6.3
Auf 7.6.3 aktualisieren
jupyterlite PyPI
- Softwareversionen
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.8.0
- 0.8.0a0
- 0.8.0a1
- 0.8.0a2
- 0.8.0b0
- 0.8.0b1
- 0.8.0rc0
- 0.8.1
- 0.8.2
- 0.8.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 0.7.0, < 0.8.4
Auf 0.8.4 aktualisieren
jupyterlite-core PyPI
- Softwareversionen
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.7.4
- 0.7.5
- 0.7.6
- 0.8.0
- 0.8.0a0
- 0.8.0a1
- 0.8.0a2
- 0.8.0b0
- 0.8.0b1
- 0.8.0rc0
- 0.8.1
- 0.8.2
- 0.8.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 0.7.0, < 0.8.4
Auf 0.8.4 aktualisieren
jupyterlab PyPI
- Softwareversionen
- 4.5.0
- 4.5.1
- 4.5.10
- 4.5.2
- 4.5.3
- 4.5.4
- 4.5.5
- 4.5.6
- 4.5.7
- 4.5.8
- 4.5.9
- 4.6.0
- 4.6.1
- 4.6.2
- 4.6.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.5.0, < 4.5.11 ∪ ≥ 4.6.0, < 4.6.4
Auf 4.5.11 aktualisieren; Auf 4.6.4 aktualisieren
notebook PyPI
- Softwareversionen
- 7.5.0
- 7.5.1
- 7.5.2
- 7.5.3
- 7.5.4
- 7.5.5
- 7.5.6
- 7.5.7
- 7.5.8
- 7.6.0
- 7.6.0a0
- 7.6.0a1
- 7.6.0a2
- 7.6.0a3
- 7.6.0a4
- 7.6.0a5
- 7.6.0b0
- 7.6.0b1
- 7.6.0rc0
- 7.6.0rc1
- 7.6.1
- 7.6.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 7.5.0, < 7.6.3
Auf 7.6.3 aktualisieren
jupyter-notebook Ubuntu:18.04:LTS
- Softwareversionen
- 4.2.3-4
- 5.1.0-2
- 5.2.1-2
- 5.2.2-1
- 5.2.2-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Ubuntu:20.04:LTS
- Softwareversionen
- 5.7.8-1
- 6.0.0-1
- 6.0.0-2
- 6.0.2-1
- 6.0.3-1
- 6.0.3-2
- 6.0.3-2ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 6.2.0-1
- 6.4.5-2
- 6.4.5-3
- 6.4.5-4
- 6.4.8-1
- 6.4.8-1ubuntu0.1
- 6.4.8-1ubuntu0.1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 6.4.12-2.2
- 6.4.12-2.2ubuntu1
- 6.4.12-2.2ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Ubuntu:26.10
- Softwareversionen
- 6.4.13-5ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab Ubuntu:26.10
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-9
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-3
- 4.4.10+ds1+~3.1.0+~0.16.6+~cs1.4.4-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyter-notebook Ubuntu:26.04:LTS
- Softwareversionen
- 6.4.13-5ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jupyterlab Ubuntu:26.04:LTS
- Softwareversionen
- 4.0.11+ds1+~cs11.25.27-7
- 4.0.11+ds1+~cs11.25.27-8
- 4.0.11+ds1+~cs11.25.27-9
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-6966-vjj6-99xv
- https://github.com/jupyterlab/jupyterlab/commit/1a10a7da5ff655849b21581c2633b46483ae0be9
- https://github.com/jupyterlab/jupyterlab/commit/7f9f29e29e0c83fb17b0f11da57d06b3c6a40d96
- https://github.com/jupyterlab/jupyterlab/commit/cf6e89a8d315c4134cefa50c220bca296da466a7
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.5.11
- https://github.com/jupyterlab/jupyterlab/releases/tag/v4.6.4
- https://nvd.nist.gov/vuln/detail/CVE-2026-102831