p PatchFirst

CVE-2026-13676

CVE-2026-13676 · fast-uri vulnerable to host confusion via failed IDN canonicalization

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Diese Seite zeigt ausgewählte Angaben aus den Quellen. Die vollständige Beschreibung und betroffene Versionen finden Sie in den verlinkten Sicherheitshinweisen.

fast-uri versions 2.3.1 through 3.1.2 and 4.0.0 fail to canonicalize Unicode (IDN) hostnames for HTTP-family URLs. The IDN conversion path calls a helper that does not exist on the global URL constructor, silently leaving the host in its original Unicode form while normalize() and equal() still return values that differ from a WHATWG-compatible URL parser. Applications that use fast-uri to enforce host-based policy (denylists, loopback filtering, redirect validation, outbound proxy routing) before passing the same URL to Node's URL or fetch can be bypassed when the two implementations resolve the same input to different hosts. Patches: upgrade to fast-uri 3.1.3 for the 3.x line or 4.0.1 for the 4.x line. Workarounds: enforce host policy using the same URL parser used for the actual request, or reject non-ASCII hosts before policy checks.

CVSS 7.5 · Hoch · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • fast-uri

    Softwareversionen
    • ≥ 4.0.0, < 4.0.1: Betroffen (semver)
    • 4.0.1: Nicht betroffen (semver)
    • ≥ 2.3.1, < 3.1.3: Betroffen (semver)
    • 3.1.3: Nicht betroffen (semver)

    Auf 3.1.3 aktualisieren; Auf 4.0.1 aktualisieren

  • node-ajv Debian:13

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-2
    • 8.20.0~ds+~cs7.1.3-3
    • 8.20.0~ds+~cs7.1.4-1
    • 8.20.0~ds+~cs7.1.5-1
    • 8.20.0~ds+~cs7.1.6-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Debian:14

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-1
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-3
    • 8.17.1~ds+~3.0.1+~3.1.0-4
    • 8.18.0~ds+~cs6.1.1-1
    • 8.18.0~ds+~cs6.1.1-2
    • 8.20.0~ds+~cs6.1.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 8.20.0~ds+~cs7.1.2-1

    Auf 8.20.0~ds+~cs7.1.2-1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.0.1

    Auf 4.0.1 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 3.0.0, < 3.1.3

    Auf 3.1.3 aktualisieren

  • fast-uri npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.3.1, < 2.4.2

    Auf 2.4.2 aktualisieren

  • node-ajv Ubuntu:18.04:LTS

    Softwareversionen
    • 5.0.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:20.04:LTS

    Softwareversionen
    • 6.10.2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:22.04:LTS

    Softwareversionen
    • 6.12.6-2
    • 6.12.6-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:24.04:LTS

    Softwareversionen
    • 6.12.6-3
    • 8.12.0~ds+~2.1.1-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:25.10

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.10

    Softwareversionen
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    • 8.20.0~ds+~cs6.1.3-1
    • 8.20.0~ds+~cs7.1.2-1
    • 8.20.0~ds+~cs7.1.3-1
    • 8.20.0~ds+~cs7.1.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-ajv Ubuntu:26.04:LTS

    Softwareversionen
    • 8.12.0~ds+~2.1.1-5
    • 8.17.1~ds+~3.0.1+~3.1.0-2
    • 8.17.1~ds+~3.0.1+~3.1.0-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →