p PatchFirst

CVE-2026-25054

CVE-2026-25054 · n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.

CVSS 8.5 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • n8n

    Softwareversionen
    • < 1.123.9: Betroffen
    • < 2.2.1: Betroffen

    Keine Korrektur veröffentlicht

  • n8n npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 2.0.0, < 2.2.1

    Auf 2.2.1 aktualisieren

  • n8n npm

    Betroffene Versionsbereiche
    • SEMVER: < 1.123.9

    Auf 1.123.9 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →