p PatchFirst

CVE-2026-25054

CVE-2026-25054 · n8n is Vulnerable to Stored Cross-Site Scripting via Markdown Rendering in Workflow UI

This page contains facts from public vulnerability sources. Check the original advisory before updating.

n8n is an open source workflow automation platform. Prior to versions 1.123.9 and 2.2.1, a Cross-Site Scripting (XSS) vulnerability existed in a markdown rendering component used in n8n's interface, including workflow sticky notes and other areas that support markdown content. An authenticated user with permission to create or modify workflows could abuse this to execute scripts with same-origin privileges when other users interact with a maliciously crafted workflow. This could lead to session hijacking and account takeover. This issue has been patched in versions 1.123.9 and 2.2.1.

CVSS 8.5 · High · EPSS 0.2% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • n8n

    Versions
    • < 1.123.9: Affected
    • < 2.2.1: Affected

    No fix published

  • n8n npm

    Affected ranges
    • SEMVER: ≥ 2.0.0, < 2.2.1

    Update to 2.2.1

  • n8n npm

    Affected ranges
    • SEMVER: < 1.123.9

    Update to 1.123.9

Original sources

Check your server →