p PatchFirst

CVE-2026-33020

CVE-2026-33020 · libsixel: Integer Overflow in write_png_to_file() leads to Heap-based Buffer Overflow

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

libsixel is a SIXEL encoder/decoder implementation derived from kmiya's sixel. Versions 1.8.7 and prior contain an integer overflow which leads to a heap buffer overflow via sixel_frame_convert_to_rgb888() in frame.c, where allocation size and pointer offset computations for palettised images (PAL1, PAL2, PAL4) are performed using int arithmetic before casting to size_t. For images whose pixel count exceeds INT_MAX / 4, the overflow produces an undersized heap allocation for the conversion buffer and a negative pointer offset for the normalization sub-buffer, after which sixel_helper_normalize_pixelformat() writes the full image data starting from the invalid pointer, causing massive heap corruption confirmed by ASAN. An attacker providing a specially crafted large palettised PNG can corrupt the heap of the victim process, resulting in a reliable crash and potential arbitrary code execution. This issue has been fixed in version 1.8.7-r1.

CVSS 7.1 · Hoch · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • libsixel

    Softwareversionen
    • < 1.8.7-r1: Betroffen

    Keine Korrektur veröffentlicht

  • libsixel Debian:12

    Softwareversionen
    • 1.10.3-3
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Debian:13

    Softwareversionen
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Debian:14

    Softwareversionen
    • 1.10.5-1
    • 1:1.8.7-1
    • 1:1.8.7-2
    • 1:1.8.7-3
    • 1:1.8.7-4
    • 1:1.8.7-5
    • 1:1.8.7-6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:1.8.7-r2-1

    Auf 1:1.8.7-r2-1 aktualisieren

  • libsixel Ubuntu:16.04:LTS

    Softwareversionen
    • 1.4.2-1
    • 1.5.2-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:18.04:LTS

    Softwareversionen
    • 1.5.2-2
    • 1.7.3-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:20.04:LTS

    Softwareversionen
    • 1.8.2-1
    • 1.8.2-2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:22.04:LTS

    Softwareversionen
    • 1.8.6-2
    • 1.10.3-2
    • 1.10.3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:24.04:LTS

    Softwareversionen
    • 1.10.3-3
    • 1.10.3-3build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:25.10

    Softwareversionen
    • 1.10.5-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:26.10

    Softwareversionen
    • 1.10.5-1build1
    • 1:1.8.7-r2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • libsixel Ubuntu:26.04:LTS

    Softwareversionen
    • 1.10.5-1
    • 1.10.5-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →